summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRené Wagner2022-05-30 08:20:57 +0200
committerRené Wagner2022-05-30 08:20:57 +0200
commit904b4ef6b7084df2ee386da0fb1a3f643f0e1db4 (patch)
tree39db0c4fbceff3e88b87ef622abebe19c573ecff /PKGBUILD
parent634c9b762646ef2c39a8f8808c1a8d2545bc89d1 (diff)
downloadaur-904b4ef6b7084df2ee386da0fb1a3f643f0e1db4.tar.gz
fix build on linux 5.18
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 00d3c0c7d463..d1d566b68b21 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
_pkgbase=r8168
pkgname=${_pkgbase}-dkms
pkgver=8.050.02
-pkgrel=1
+pkgrel=2
pkgdesc="A kernel module for Realtek 8168 network cards (DKMS version)"
url="https://github.com/mtorromeo/r8168"
license=("GPL")
@@ -16,11 +16,18 @@ depends=('glibc' 'dkms')
makedepends=('git')
conflicts=("${pkgname}")
source=("r8168-dkms::git+https://github.com/mtorromeo/r8168.git"
- "dkms.conf")
+ "dkms.conf"
+ "linux518.patch::https://raw.githubusercontent.com/archlinux/svntogit-community/packages/r8168/trunk/linux518.patch")
sha256sums=('SKIP'
- 'e33abcbc8fbe3129459ebc60be3b2f8ed55ddc53755f4956d6feb16c61c43250')
+ 'e33abcbc8fbe3129459ebc60be3b2f8ed55ddc53755f4956d6feb16c61c43250'
+ 'd8d542770e504775600f686d03412a37cc32489872be7aeb388b5b08d9806096')
install=r8168-dkms.install
+prepare() {
+ cd "$pkgname"
+ patch -Np1 -i ../linux518.patch
+}
+
package() {
install -Dm644 dkms.conf "${pkgdir}/usr/src/${_pkgbase}-${pkgver}/dkms.conf"