summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwangjiezhe2016-04-20 22:20:53 +0800
committerwangjiezhe2016-04-20 22:20:53 +0800
commitff603395a65e83e8456cda50f7beff68afea0a5b (patch)
treeee833866d39b280090630a9919f9ce2f1fec78d8 /PKGBUILD
parentcc1009a771df022cf323daf8edca4bbfeeef2a83 (diff)
downloadaur-ff603395a65e83e8456cda50f7beff68afea0a5b.tar.gz
Update for linux-pf 4.5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 55d2910c1df9..b07b40402b46 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
_pkgname=r8168
pkgname=r8168-pf
pkgver=8.041.00
-pkgrel=3
+pkgrel=4
pkgdesc="A kernel module for Realtek 8168 network cards(pf kernel)"
url="http://www.realtek.com.tw"
license=("GPL")
@@ -14,8 +14,15 @@ arch=('i686' 'x86_64')
depends=('glibc' 'linux-pf')
makedepends=('linux-pf-headers')
install=$_pkgname.install
-source=("$_pkgname-$pkgver.tar.gz"::"https://github.com/mtorromeo/r8168/archive/$pkgver.tar.gz")
-sha256sums=('d56f60e4157ccbf8f8717270b1acb391b0a959d9a96c2f0b4a91c683aa8b83a5')
+source=("$_pkgname-$pkgver.tar.gz"::"https://github.com/mtorromeo/r8168/archive/$pkgver.tar.gz"
+ "linux-4.5.patch")
+sha256sums=('d56f60e4157ccbf8f8717270b1acb391b0a959d9a96c2f0b4a91c683aa8b83a5'
+ 'e05a4bccf28beecc97db246064a5fe80d1303476b76086bd262c9c8db82b2e6e')
+
+prepare() {
+ cd "$_pkgname-$pkgver"
+ patch -p1 -i ../linux-4.5.patch
+}
build() {
_kernver=$(pacman -Q linux-pf | sed -r 's#.* ([0-9]+\.[0-9]+).*#\1#')