summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorZeph2017-06-26 18:14:17 +0000
committerZeph2017-06-26 18:14:17 +0000
commit07787a71ad0f07daf07c6b7fd5b80c4eb8633013 (patch)
tree101a9421203553c31898b73cb113a512c81daaad /PKGBUILD
parentf4633e44c310b4846d5fff5c8be02c7cc2209c95 (diff)
downloadaur-07787a71ad0f07daf07c6b7fd5b80c4eb8633013.tar.gz
Error urllib
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index de54fd796028..8974af059b62 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=rabbitvcs
pkgver=0.17
-pkgrel=1
+pkgrel=2
pkgdesc="A project with the goal of developing a collection of utilities to allow for better client integration with some of the popular version control systems (core)"
arch=('any')
#url="http://rabbitvcs.org/"
@@ -31,6 +31,7 @@ build() {
cd "$srcdir/$pkgname-$pkgver"
sed -i "s#env python#env python2#" setup.py
sed -i "s#!= 'Darwin'#== 'toto'#" setup.py
+ sed -i "s#import hashlib#import hashlib, urllib#" ./rabbitvcs/util/helper.py
find . -name "*.py" | xargs grep -l sys.executable | xargs sed -i 's|sys\.executable|"/usr/bin/python2"|g'
python2 setup.py build
}