summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorl0gic2015-07-07 22:24:31 +0200
committerl0gic2015-07-07 22:24:31 +0200
commit266233999a57e48053df18eb2f76eecfd2381a15 (patch)
tree9a432a5825952c7df44d7859d26f1df43fc283ec /PKGBUILD
parentb30fbd1da163df2d88548fb0f7cf33de17569a1c (diff)
downloadaur-266233999a57e48053df18eb2f76eecfd2381a15.tar.gz
Removed actual binding in favor of r2pipe
r2pipe is the officialy favoured way of interacting with r2 from scripts
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 3 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 27ce99d90c30..bb70b7114ba8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=radare2-bindings-git
-pkgver=20150603.484.a938e31
+pkgver=20150705.507.d02e5b9
pkgrel=1
pkgdesc="Language bindings for radare2 (git version)"
arch=('i686' 'x86_64')
@@ -22,20 +22,12 @@ pkgver () {
build() {
cd "${srcdir}/${pkgname}"
- ./configure --prefix=/usr --enable=ctypes --enable=python
- (cd ./python && make)
- (cd ./ctypes && make)
- (cd ./libr/lang/p && make)
+ (cd r2pipe/python && python setup.py build)
}
package() {
cd "${srcdir}/${pkgname}"
- make DESTDIR="${pkgdir}/" install-vapi
- make DESTDIR="${pkgdir}/" install-python
- make DESTDIR="${pkgdir}/" install-plugins
- make DESTDIR="${pkgdir}/" install-ctypes
-
- rm -rf "${srcdir}"
+ (cd r2pipe/python && python setup.py install --root "${pkgdir}")
}
# vim:set ts=2 sw=2 et: