summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorl0gic2021-06-18 17:37:21 +0200
committerl0gic2021-06-18 17:37:21 +0200
commit8c6aae86d2a3e99076bc9e067fa7c23ad2d76b05 (patch)
tree65527e74e92948bc1bd315abad59bf938c3c789e /PKGBUILD
parented75ddfa5836c3d7dafddd4a4a2e04cea005bea8 (diff)
downloadaur-8c6aae86d2a3e99076bc9e067fa7c23ad2d76b05.tar.gz
Fix libr_util.so linking issue
libr_util.so fails to link with PIE, so we explicitly remove it from CFLAGS. ``` (.text+0x24): undefined reference to `main' collect2: error: ld returned 1 exit status ``` This also includes the fix for CVE-2021-32613.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4ff8b1841f7d..6699613a869d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: 0xAA <0xaa at dmg dot sx>
# Contributor: bratus <szczepaniak.bartek plus github at gmail dot com>
pkgname=radare2-git
-pkgver=5.1.0.r25401.89ff9aaf6e
+pkgver=5.4.0.r26148.86f8c9dce6
pkgrel=1
pkgdesc="Open-source tools to disasm, debug, analyze and manipulate binary files"
arch=('i686' 'x86_64')
@@ -27,6 +27,8 @@ build() {
# you can comment this out, if you build in a clean environment
export PKG_CONFIG_PATH="${srcdir}/${pkgname}/pkgcfg:${PKG_CONFIG_PATH}"
+ CFLAGS="${CFLAGS//-fPIE -pie}"
+
cd ${srcdir}/${pkgname}
touch libr/config.mk
arch-meson build \