summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRoshless2022-02-21 11:52:43 +0100
committerRoshless2022-02-21 11:53:36 +0100
commit1bb8b28caa898960520d491bd4c9a5684dc5ae7f (patch)
treef1a58e5f02e8d6de32074ebdea53686ed2dd09fd /PKGBUILD
parent60f63e3a806168e43a7b1c4cb8e8065eccb0516d (diff)
downloadaur-1bb8b28caa898960520d491bd4c9a5684dc5ae7f.tar.gz
upgpkg: radeon-profile-git 20200824.r22.g295d189-1
move to https://github.com/emerge-e-world/radeon-profile
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 19 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9086fe1bb58c..eb5e025449e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: marazmista <marazmista@tuta.io>
pkgname=radeon-profile-git
-pkgver=20200504.r0.g2e0b4d9
+pkgver=20200824.r22.g295d189
pkgrel=1
pkgdesc="App for display info about radeon card"
-url="http://github.com/marazmista/radeon-profile"
+url="http://github.com/emerge-e-world/radeon-profile"
arch=('i686' 'x86_64')
license=('GPL2')
depends=('qt5-base' 'qt5-charts' 'libxkbcommon-x11' 'libxrandr')
@@ -18,33 +18,30 @@ optdepends=('radeon-profile-daemon: system daemon for reading card info'
'xf86-video-amdgpu: amdgpu open source driver')
provides=('radeon-profile')
replaces=('radeon-profile')
-source=("git+https://github.com/marazmista/radeon-profile.git")
+source=("git+https://github.com/emerge-e-world/radeon-profile.git")
sha256sums=('SKIP')
pkgver() {
-cd "$srcdir/radeon-profile"
-git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "$srcdir/radeon-profile"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
-cd "$srcdir/radeon-profile/radeon-profile"
-
-lrelease radeon-profile.pro
-qmake-qt5 QMAKE_CFLAGS_RELEASE="${CFLAGS}" QMAKE_CXXFLAGS_RELEASE="${CXXFLAGS}" CONFIG+=silent
-make
+ cd "$srcdir/radeon-profile/radeon-profile"
+ lrelease radeon-profile.pro
+ qmake-qt5 QMAKE_CFLAGS_RELEASE="${CFLAGS}" QMAKE_CXXFLAGS_RELEASE="${CXXFLAGS}" CONFIG+=silent
+ make
}
package() {
-cd "$srcdir/radeon-profile/radeon-profile"
-
-install -Dm755 "target/radeon-profile" "$pkgdir/usr/bin/radeon-profile"
-
-install -Dm644 "extra/radeon-profile.png" "$pkgdir/usr/share/pixmaps/radeon-profile.png"
-install -Dm644 "extra/radeon-profile.desktop" "$pkgdir/usr/share/applications/radeon-profile.desktop"
-
-cd translations
-for translation in *.qm
-do
-install -Dm644 $translation "$pkgdir/usr/share/radeon-profile/$translation"
-done
+ cd "$srcdir/radeon-profile/radeon-profile"
+ install -Dm755 "target/radeon-profile" "$pkgdir/usr/bin/radeon-profile"
+ install -Dm644 "extra/radeon-profile.png" "$pkgdir/usr/share/pixmaps/radeon-profile.png"
+ install -Dm644 "extra/radeon-profile.desktop" "$pkgdir/usr/share/applications/radeon-profile.desktop"
+
+ cd translations
+ for translation in *.qm
+ do
+ install -Dm644 $translation "$pkgdir/usr/share/radeon-profile/$translation"
+ done
}