summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormarazmista2016-10-03 22:15:40 +0200
committermarazmista2016-10-03 22:15:40 +0200
commita2914a3907623c0744c6e7895936e89dab0a5f6c (patch)
tree93e39692fa17ab9f2735280709dff4d59f4391c2 /PKGBUILD
parentbcf3a16ed30b3753abe8e2dd0585009bcf635d76 (diff)
downloadaur-a2914a3907623c0744c6e7895936e89dab0a5f6c.tar.gz
20161003 git release, updated .SRCINFO
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD52
1 files changed, 27 insertions, 25 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d87fd00aa81a..4efacb1e6046 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,49 +1,51 @@
# Maintainer: marazmista <marazmista@gmail.com>
pkgname=radeon-profile-git
-pkgver=20160527
-pkgrel=2
+pkgbase=radeon-profile
+pkgver=20161003.r0.g4347b27
+pkgrel=1
pkgdesc="App for display info about radeon card"
url="http://github.com/marazmista/radeon-profile"
arch=('i686' 'x86_64')
license=('GPL2')
depends=('qt5-base' 'libxkbcommon-x11' 'libxrandr')
-makedepends=('qt5-tools')
+makedepends=('qt5-tools')
optdepends=('radeon-profile-daemon: system daemon for reading card info'
- 'lm_sensors: to show gpu temperature'
- 'sudo: start with root privilages without password'
- 'mesa-demos: for glxinfo'
- 'xorg-xdriinfo: display driver name'
+ 'lm_sensors: to show gpu temperature'
+ 'sudo: start with root privilages without password'
+ 'mesa-demos: for glxinfo'
+ 'xorg-xdriinfo: display driver name'
'xorg-xrandr: show card connected outputs'
'xf86-video-ati: radeon open source driver')
provides=('radeon-profile')
replaces=('radeon-profile')
-source=('git+https://github.com/marazmista/radeon-profile.git')
+source=("git+https://github.com/marazmista/$pkgbase.git")
sha256sums=('SKIP')
-
-build() {
-mkdir -p build
-cd build
-lrelease ../radeon-profile/radeon-profile/radeon-profile.pro
-cp ../radeon-profile/radeon-profile/*.qm .
+pkgver() {
+cd "$srcdir/$pkgbase"
+git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+cd "$srcdir/$pkgbase/radeon-profile"
-qmake-qt5 "../radeon-profile/radeon-profile/"
+lrelease radeon-profile.pro
+qmake-qt5
make
}
-
+
package() {
-cd build
-make prefix="${pkgdir}" install
+cd "$srcdir/$pkgbase/radeon-profile"
-install -Dm644 "$srcdir/build/radeon-profile" "$pkgdir/usr/bin/radeon-profile"
-chmod +x "$pkgdir/usr/bin/radeon-profile"
+install -Dm755 "radeon-profile" "$pkgdir/usr/bin/radeon-profile"
-install -Dm644 "$srcdir/radeon-profile/radeon-profile/extra/radeon-profile.png" "$pkgdir/usr/share/pixmaps/radeon-profile.png"
-install -Dm644 "$srcdir/radeon-profile/radeon-profile/extra/radeon-profile.desktop" "$pkgdir/usr/share/applications/radeon-profile.desktop"
+install -Dm644 "extra/radeon-profile.png" "$pkgdir/usr/share/pixmaps/radeon-profile.png"
+install -Dm644 "extra/radeon-profile.desktop" "$pkgdir/usr/share/applications/radeon-profile.desktop"
+cd translations
for translation in *.qm
do
-install -Dm644 "$translation" "$pkgdir/usr/share/radeon-profile/$translation"
-done
-} \ No newline at end of file
+install -Dm644 $translation "$pkgdir/usr/share/radeon-profile/$translation"
+done
+}