summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAntonio Arias Orzanco2023-10-16 20:28:44 +0200
committerAntonio Arias Orzanco2023-10-16 20:28:44 +0200
commitd9a4e272392ccf92656cae02adb75063d8dca505 (patch)
tree0562012668c4bebabedcb99dd8c99275ea844c2d /PKGBUILD
downloadaur-d9a4e272392ccf92656cae02adb75063d8dca505.tar.gz
Creating initial aur package.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cf33b41d2a17
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Antonio Arias Orzanco <antonio dot arias99999 at gmail dot com>
+
+_name=pyradios
+pkgname=python-$_name
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="Python client for the Radio Browser API."
+arch=('any')
+url="https://github.com/andreztz/pyradios"
+license=('GPL3')
+depends=('python')
+makedepends=('python-setuptools')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/andreztz/pyradios/archive/refs/tags/v$pkgver.tar.gz")
+md5sums=('ed512d3607f29b5568534b12e1d2035c')
+
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --skip-build --optimize=1
+ rm -rf $pkgdir/usr/lib/python3.11/site-packages/tests
+}
+