summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonathon Fernyhough2017-07-05 20:13:26 +0100
committerJonathon Fernyhough2017-07-05 20:18:41 +0100
commit3c9c7800ce3f679629c4bcb7ad9e9ce4e1eabba3 (patch)
treec27f2c0fd5ec0ae2ec49999ccfb4de09356a2393 /PKGBUILD
parent5cbd981499397a21b36e7e64165b1b25e5f1c061 (diff)
downloadaur-3c9c7800ce3f679629c4bcb7ad9e9ce4e1eabba3.tar.gz
Massive overhaul for GStreamer 1.0 and GTK3.
Massive props to Debian maintainers - this PKGBUILD includes three patches lifted directly from the Debian package, with a small change to ensure python2 is used in radiotray_runner. I also switched from a source-based install to a bdist; this cuts the package size though it also means you can't link to radiotray any more (is that needed?).
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD60
1 files changed, 39 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b979f2281726..dca1fdbc2b2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,50 @@
+# Maintainer: Jonathon Fernyhough <jonathon_at_manjaro_dot_org>
# Contributor: Yarema aka Knedlyk <yupadmin@gmail.com>
-# Maintainer: zoe <chp321 [at] gmail [dot] com>
+# Contributor: zoe <chp321 [at] gmail [dot] com>
pkgname=radiotray
pkgver=0.7.3
-pkgrel=9
-commit=1717a0e8c143
+pkgrel=10
+_commit=1717a0e8c143
pkgdesc="An online radio streaming player that runs on a Linux system tray."
arch=(any)
-url="http://radiotray.wordpress.com/"
+url="https://radiotray.wordpress.com/"
license=(GPL)
-depends=('gstreamer' 'gstreamer0.10-base-plugins' 'gstreamer0.10-python' 'pygtk' \
-'python2-notify' 'python2-xdg' 'python2-dbus' 'gstreamer0.10-good-plugins' \
-'python2-gobject' 'python2-lxml')
-optdepends=('gstreamer0.10-bad-plugins' 'gstreamer0.10-ugly-plugins' 'gstreamer0.10-ffmpeg')
+depends=('gstreamer' 'gst-plugins-base' 'gst-plugins-good' 'gst-python2' \
+ 'pygtk' 'python2-notify' 'python2-xdg' 'python2-dbus' \
+ 'python2-gobject' 'python2-lxml')
+optdepends=('gst-plugins-bad' 'gst-plugins-ugly' 'gst-libav')
makedepends=(python2)
-provides=(radiotray)
-source=(https://bitbucket.org/carlmig/radio-tray/get/${pkgname}-${pkgver}.tar.gz
- encoding.patch
- gtk.patch)
+provides=("${pkgname}")
+source=("${pkgname}-${pkgver}.tar.gz::https://bitbucket.org/carlmig/radio-tray/get/${pkgname}-${pkgver}.tar.gz"
+ "encoding.patch"
+ "02_compatibility_glib-2.41.patch"
+ "03_upstream_repo.patch"
+ "04_gtk3_issues.patch")
conflicts=(radiotray-hg radiotray-python3-git)
+
+sha256sums=('464c555b8d9278e918d3718f81a1c0cfa7d9a54018d1a2f6b04b33dc40ea825c'
+ 'a73badc0ddbf726d3f554e328b8836883bf816751cd0dc2034795a03466cd2df'
+ 'b6d1d7fe74be1ec2ecad653262111f509d6fd60b8e666eb5e15d7bcb21e7a58b'
+ '04748958923e3c2cac8944700a0786d066ab17d8284155adf316adab78dd0c55'
+ 'c67845683a6d7d63eb26bbefe3c06921e0e6cbc2a5cb32c58b47377fdeb83644')
+
+prepare() {
+ cd "${srcdir}/carlmig-radio-tray-${_commit}"
+ patch -p1 < "${srcdir}/encoding.patch"
+ patch -p1 < "${srcdir}/02_compatibility_glib-2.41.patch"
+ patch -p1 < "${srcdir}/03_upstream_repo.patch"
+ patch -p1 < "${srcdir}/04_gtk3_issues.patch"
+}
+
+build() {
+ cd "${srcdir}/carlmig-radio-tray-${_commit}"
+ python2 setup.py bdist
+}
+
package() {
- cd $srcdir/carlmig-radio-tray-$commit
- patch -p1 < $srcdir/encoding.patch || return 1
- patch -p1 < $srcdir/gtk.patch || return 1
- mkdir $pkgdir/usr
- python2 setup.py install --root=${pkgdir}/ --optimize=1 || return 1
- chmod +x $pkgdir/usr/bin/radiotray || return 1
+ cd "${srcdir}/carlmig-radio-tray-${_commit}"
+ tar xf "dist/${pkgname}-${pkgver}.linux-${CARCH}.tar.gz" -C "${pkgdir}"
+ chown -R root: ${pkgdir}
}
-md5sums=('33d30ba8d2a293382f60990b761d1d38'
- '3f3fe97dfe4fef65af8345d24fd19a2e'
- '0ef80483af7a7a627e5d1dbef978d6fc')
+