summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJakob Gahde2017-04-11 20:42:48 +0200
committerJakob Gahde2017-04-11 20:42:48 +0200
commitbc35a753a2f40b8694c6e9ee3371ef16e49cbe3e (patch)
tree441f27f3e17388a1afe60b0bd622d338a4f8d7c4 /PKGBUILD
parentbbab74e41fc917c71131a26da54a3423e3a3add4 (diff)
downloadaur-bc35a753a2f40b8694c6e9ee3371ef16e49cbe3e.tar.gz
radium 4.6.6-1: New version w/ changes courtesy of Teteros
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD55
1 files changed, 30 insertions, 25 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c21139075fed..a5cad71547dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,17 @@
# Maintainer: Karol "Kenji Takahashi" Woźniak <kenji.sx>
# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
+# Contributor: Teteros <teteros -at- opmbx -dot- org>
pkgname=radium
-pkgver=4.5.0
+pkgver=4.6.6
pkgrel=1
pkgdesc="A graphical music editor. A next generation tracker."
arch=('i686' 'x86_64')
-url="http://users.notam02.no/~kjetism/radium/"
+url="https://users.notam02.no/~kjetism/radium/"
license=('GPL')
depends=(
'python2'
'libxaw'
- 'libsndfile'
- 'libsamplerate'
'liblrdf'
'qt5-webkit'
'qt5-x11extras'
@@ -23,7 +22,9 @@ depends=(
'jack'
'libxinerama'
'libxcursor'
+ 'hicolor-icon-theme'
)
+optdepends=('calf-ladspa' 'ladspa-plugins')
makedepends=(
'cmake'
'boost'
@@ -34,35 +35,20 @@ makedepends=(
)
options=(!strip)
source=("https://github.com/kmatheussen/${pkgname}/archive/${pkgver}.tar.gz"
- "faust-accept-current-clang.patch"
"dont-empty-qt-library-paths.patch"
- "fix-misleading-indentation.patch"
- "fix-X11_keyboard-compilation.patch"
"use-system-libxcb.patch"
"use-system-vstsdk.patch")
-md5sums=('e2bddd56d0e9dc3a9cdf89249a3915ef'
- 'df250d13d5826b35c9139e6d436ebac9'
- '77c202bc0a36562eb7b805ad6b7a85b3'
- '1ca36c75ce4b3fed28c22753b8dc045a'
- '24e927620d8aeb09c83b903a92dacf9f'
- '60e99f9362d08726877d14ea2cdfd5c6'
- '5c78211475528b588cabced5f024eb54')
+md5sums=('4a2e4050ce8350d1d0287524b4916cd2'
+ 'd63cea387564fa21dee775e764206a45'
+ 'd798d5655e2899dc1b54f797d9b2bda3'
+ 'd068d4bc99360cd4ec933c57ab9f5159')
prepare() {
cd "${pkgname}-${pkgver}"
- msg2 "Fixing faust2 compilation on llvm 3.9.1"
- patch -Nsp1 < "${srcdir}/faust-accept-current-clang.patch"
-
msg2 "Fixing QT_QPA_PLATFORM_PLUGIN_PATH problem"
patch -Nsp1 < "${srcdir}/dont-empty-qt-library-paths.patch"
- msg2 "Fixing misleading indentation"
- patch -Nsp1 < "${srcdir}/fix-misleading-indentation.patch"
-
- msg2 "Fixing X11_keyboard compilation"
- patch -Nsp1 < "${srcdir}/fix-X11_keyboard-compilation.patch"
-
msg2 "Switching to systemd-wide libxcb"
patch -Nsp1 < "${srcdir}/use-system-libxcb.patch"
@@ -97,12 +83,31 @@ package() {
msg2 "Installing s7 sources"
install -dm755 "${pkgdir}/opt/radium/packages"
tar -xf "bin/packages/s7.tar.gz" -C "${pkgdir}/opt/radium/packages" \
- --no-same-owner --no-same-permissions --wildcards '*.scm'
+ --no-same-owner --no-same-permissions --wildcards '*.scm'
# Radium will complain if these are missing
msg2 "Installing Faust GUI styles"
install -Dm644 -t "${pkgdir}/opt/radium/packages/faust2/architecture/faust/gui/Styles" \
- "bin/packages/faust2/architecture/faust/gui/Styles/"*".qss"
+ "bin/packages/faust2/architecture/faust/gui/Styles/"*".qss"
+
+ msg2 "Installing .desktop, icon and mimetype files"
+ install -dm755 "${pkgdir}/usr/share/applications"
+ ln -s "/opt/radium/radium.desktop" \
+ "${pkgdir}/usr/share/applications/radium.desktop"
+
+ install -dm755 "${pkgdir}/usr/share/icons/hicolor/"{256x256,128x128,32x32,16x16}"/apps"
+ ln -s "/opt/radium/radium_256x256x32.png" \
+ "${pkgdir}/usr/share/icons/hicolor/256x256/apps/radium.png"
+ ln -s "/opt/radium/radium_128x128x32.png" \
+ "${pkgdir}/usr/share/icons/hicolor/128x128/apps/radium.png"
+ ln -s "/opt/radium/radium_32x32x24.png" \
+ "${pkgdir}/usr/share/icons/hicolor/32x32/apps/radium.png"
+ ln -s "/opt/radium/radium_16x16x8.png" \
+ "${pkgdir}/usr/share/icons/hicolor/16x16/apps/radium.png"
+
+ install -dm755 "${pkgdir}/usr/share/mime/packages"
+ ln -s "/opt/radium/radium-mimetype.xml" \
+ "${pkgdir}/usr/share/mime/packages/radium.xml"
}
# vim:set ts=4 sw=4 et: