summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJesse R. Adams2015-08-08 06:50:17 -0700
committerJesse R. Adams2015-08-08 06:50:17 -0700
commite3241518a64a65e71217fb54377255d1d3143f04 (patch)
tree5cc1d49e06d10263dcc2b6acc811774554f2807d /PKGBUILD
downloadaur-rainbarf-git.tar.gz
Initial import for AUR4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f41ccaa5117b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Jesse R. Adams <jesse -at- techno -dash- geeks -dot- org>
+pkgname=rainbarf-git
+pkgver=20140404
+pkgrel=1
+pkgdesc="CPU/RAM stats chart for tmux & screen"
+url="http://freecode.com/projects/rainbarf"
+arch=('i686' 'x86_64' 'arm')
+license=('GPL')
+#depends=()
+optdepends=('tmux' 'screen')
+makedepends=('git')
+provides=('rainbarf')
+conflicts=('rainbarf')
+source=()
+md5sums=()
+sha256sums=()
+
+_gitroot="git://github.com/creaktive/rainbarf.git"
+_gitname="rainbarf"
+
+build() {
+ cd $srcdir
+ msg "Connecting to the git repository..."
+
+ if [ -d $srcdir/$_gitname ] ; then
+ cd $_gitname && git pull origin
+ msg "The local files are updated."
+ else
+ git clone $_gitroot
+ fi
+ msg "GIT checkout done or server timeout"
+}
+
+package() {
+ msg "Copying files..."
+ mkdir -p "${pkgdir}/usr/bin"
+ install -m755 "${srcdir}/${_gitname}/rainbarf" "${pkgdir}/usr/bin/" || return 1
+}