summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabio2017-11-04 14:13:41 +0100
committerFabio2017-11-04 14:13:41 +0100
commit4d6cdbd5c2fcdbd07de0a7eb09b741df90747c77 (patch)
tree110dd819d951d7b6b07ffcb0f71fa3ba78d0a990 /PKGBUILD
parentecccdb4daac0c939e6faa7c8dbf0c221bdd09472 (diff)
downloadaur-4d6cdbd5c2fcdbd07de0a7eb09b741df90747c77.tar.gz
update to v0.1.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 12 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 251e546b65cd..cce25eb7eb49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Fabio Rämi <fabio[at]dynamix-tontechnik[dot]ch>
pkgname=raiseorlaunch
-pkgver=0.1.1
-pkgrel=4
+pkgver=0.1.2
+pkgrel=0
pkgdesc="Run-or-raise-application-launcher for i3 window manager."
arch=(any)
url="https://github.com/open-dynaMIX/raiseorlaunch"
@@ -10,11 +10,16 @@ license=('MIT')
depends=('python' 'python-i3-py')
makedepends=('python-setuptools' 'python-pip' 'python-wheel')
source=("https://github.com/open-dynaMIX/${pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=('c2984485721479404f397d4496792a2f6b5894a291cac6768049232aedf9de26')
+sha256sums=('0203371a92993dcfa61e7be7c9b28d08bc6f75d1f63ebf0fab2ef79e55b1397c')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ # Need to create the wheel first, otherwise the generated entry script will be too slow
+ python setup.py bdist_wheel
+}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- # Need to create the wheel first, otherwise the generated entry script will be too slow
- python setup.py bdist_wheel
- PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps dist/${pkgname}-${pkgver}-py2.py3-none-any.whl
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ PIP_CONFIG_FILE=/dev/null pip install --isolated --root="${pkgdir}" --ignore-installed --no-deps dist/${pkgname}-${pkgver}-py2.py3-none-any.whl
+ install -Dm644 LICENSE.txt "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
}