summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTrumeet2022-01-19 01:04:52 -0800
committerTrumeet2022-01-19 01:04:52 -0800
commit302570635946a2d19fadbf405486130c6f1bb922 (patch)
treebfb4fd4a5ef2a3511bfae724895af706c0862e40 /PKGBUILD
parente40f348318272920eeae841e9e86a92d8091c66f (diff)
downloadaur-302570635946a2d19fadbf405486130c6f1bb922.tar.gz
Support @ services
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 6 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d7c438f2bfc9..0a12d52f2f77 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,12 +21,16 @@ install=
changelog=
source=("https://gitlab.com/NickCao/RAIT/-/archive/v$pkgver/RAIT-v$pkgver.tar.gz"
"rait.service"
+"rait@.service"
"rait-metrics.service"
+"rait-metrics@.service"
"rait.conf")
noextract=()
sha256sums=('c5c45746ccd0fc4077980dd3bff36efb35003eb91935698e91d81ecf53865e6f'
'f43c04d33ca5f747d906bff3f00f40fb616f769106b07c754e42510ccb1b45cc'
+ 'eab1a48388b66f1ee7c323fdfe5c9098752cf5cb3fe2056d783cc9e6d19fd2de'
'db6854d47284aa1e902edbc01911d48311de82bef3d81fd1f0ca3f67dbea0cb4'
+ '0a793cd28d849ca3048c56c4ad31af69becb40af173789235efed26dc8612536'
'7f85c1f0f3979bce2072974b423964aeeb95f05176e0c06bf264b55ff51e53c3')
validpgpkeys=()
@@ -55,7 +59,9 @@ package() {
cd ..
mkdir -p "$pkgdir"/usr/lib/systemd/system/
install -Dm644 rait.service "$pkgdir"/usr/lib/systemd/system/
+ install -Dm644 rait@.service "$pkgdir"/usr/lib/systemd/system/
install -Dm644 rait-metrics.service "$pkgdir"/usr/lib/systemd/system/
+ install -Dm644 rait-metrics@.service "$pkgdir"/usr/lib/systemd/system/
mkdir -p "$pkgdir"/etc/rait/
install -Dm600 rait.conf "$pkgdir"/etc/rait/
}