summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzxp198210052023-06-06 16:36:02 +0800
committerzxp198210052023-06-06 16:36:02 +0800
commit57db192deada4fc4f4eed1df4f6acfe4d502c6ad (patch)
tree7204873c6d0e57b1e374c55071a62152c7c0a3ab /PKGBUILD
downloadaur-57db192deada4fc4f4eed1df4f6acfe4d502c6ad.tar.gz
first release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f207d2f2846
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname="raj-browser-bin"
+pkgver=2.0.5
+pkgrel=1
+pkgdesc="A UI and privacy focussed browser for the web from the web."
+arch=('x86_64')
+license=('custom')
+conflicts=("${pkgname%-bin}")
+url="https://github.com/Rajaniraiyn/raj-browser"
+depends=('nspr' 'libcups' 'libxkbcommon' 'libxrandr' 'libxcb' 'libxcomposite' 'dbus' 'gcc-libs' 'libx11' 'cairo' 'at-spi2-core' 'nss' \
+ 'gtk3' 'hicolor-icon-theme' 'libxdamage' 'pango' 'alsa-lib' 'glibc' 'wayland' 'libdrm' 'libxfixes' 'glib2' 'libxext' 'expat' 'mesa')
+source=("${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/v${pkgver}/${pkgname%-bin}_${pkgver}_amd64.deb")
+sha256sums=('b0ff6a0abff0fe3f8510aa5f12bae954eab07cb0441ee5971685d3335fa91b79')
+package(){
+ bsdtar -xf data.tar.xz -C "${pkgdir}"
+ sed "s|Utility|Network;Utility|g" -i "${pkgdir}/usr/share/applications/${pkgname%-bin}.desktop"
+ install -Dm644 "${pkgdir}/opt/${pkgname%-bin}/LICENSE"* -t "${pkgdir}/usr/share/licenses/${pkgname}"
+} \ No newline at end of file