summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzxp198210052024-02-28 12:11:54 +0800
committerzxp198210052024-02-28 12:11:54 +0800
commit6cf0ff58e93a92c1b7749931d5d33ded6788ccff (patch)
treec4bfcedbcc55a5f821d67fbbb8ce38139d8d14f6 /PKGBUILD
parent3549357cd07498140532773e44522ca34248706c (diff)
downloadaur-6cf0ff58e93a92c1b7749931d5d33ded6788ccff.tar.gz
fix errors
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 83a91b227f67..acfd6317cd46 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,10 @@
pkgname=raj-browser-bin
pkgver=2.0.5
_electronversion=22
-pkgrel=5
+pkgrel=6
pkgdesc="A UI and privacy focussed browser for the web from the web."
arch=('x86_64')
-license=('custom')
+license=('Apache-2.0')
conflicts=("${pkgname%-bin}")
url="https://github.com/Rajaniraiyn/raj-browser"
depends=(
@@ -16,13 +16,13 @@ source=(
"${pkgname%-bin}.sh"
)
sha256sums=('b0ff6a0abff0fe3f8510aa5f12bae954eab07cb0441ee5971685d3335fa91b79'
- 'd4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
+ '0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
- -e "s|@appasar@|app.asar|g" \
+ -e "s|@runname@|app.asar|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
- bsdtar -xf "${srcdir}/data.tar.xz"
+ bsdtar -xf "${srcdir}/data."*
sed "s|/opt/${pkgname%-bin}/${pkgname%-bin}|${pkgname%-bin}|g;s|Utility|Network|g" \
-i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
}