summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGoliathLabs2020-05-28 14:32:31 +0200
committerGoliathLabs2020-05-28 14:32:31 +0200
commitcac89838f20becc1becf81e199e791c77b04edd8 (patch)
tree4c0ee4d779da2dada1f2138d9d06925017ed9734 /PKGBUILD
parent005a9a3546f3c885ff68ef0dc822cc96e87e3bab (diff)
downloadaur-cac89838f20becc1becf81e199e791c77b04edd8.tar.gz
Updated: 0.7.5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 11 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 430d376dbfa1..e2fc3495f058 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,21 @@
-# Maintainer: Philipp A. <flying-sheep@web.de>
+# Maintainer: Alfredo Palhares <alfredo@palhares.me>
+# Co-Maintainer: Felix Golatofski <contact@xdfr.de>
+# Contributor: Philipp A. <flying-sheep@web.de>
pkgname=rambox
-pkgver=0.5.17
-pkgrel=3
+pkgver=0.7.5
+pkgrel=1
pkgdesc='Free and Open Source messaging and emailing app that combines common web applications into one.'
arch=(i686 x86_64)
depends=(electron)
makedepends=(desktop-file-utils asar ruby npm sencha-cmd-6)
url='http://rambox.pro/'
license=(GPL3)
-source=("https://github.com/saenzramiro/$pkgname/archive/$pkgver.tar.gz"
- "https://github.com/saenzramiro/$pkgname/releases/download/$pkgver/Rambox-$pkgver-x64.tar.gz"
+source=("https://github.com/ramboxapp/community-edition/archive/$pkgver.tar.gz"
+ "https://github.com/ramboxapp/community-edition/releases/download/$pkgver/Rambox-$pkgver-linux-x64.tar.gz"
"$pkgname.desktop" "$pkgname.js")
-sha256sums=('7759ae13ac15252200a0211d145d16dc69a3be83813033ea779b9573fdebac9e'
- 'e1167d03c28107f77a1c1ed530d2a47651d4b24994b2e10a9cebf7adeb90e207'
+sha256sums=('a9f8fd67d93b193b82e6aaf57971303297918f581dae80e5dcd907ae43e348dc'
+ '12400d7c774eb360e3dd15dc356af0a72b9f5813ca829cd436f9b274aaf3e67a'
'61ad70a929c402e24c79b8868208310f9b3c4d7801db2b791af38293231ee524'
'3b5ed6f04eea66f239b5ae56ea1ff9e47de156cd38bb54ebc46541daba6091b6')
noextract=("Rambox-$pkgver-x64.tar.gz")
@@ -21,7 +23,7 @@ noextract=("Rambox-$pkgver-x64.tar.gz")
build() {
# retrieve env.js
cd "$srcdir"
- tar xOf "Rambox-$pkgver-x64.tar.gz" "Rambox-$pkgver/resources/app.asar" >app.asar
+ tar xOf "Rambox-$pkgver-linux-x64.tar.gz" "Rambox-$pkgver-linux-x64/resources/app.asar" >app.asar
mv "community-edition-$pkgver" "$pkgname-$pkgver"
cd "$pkgname-$pkgver"
asar ef ../app.asar env.js
@@ -32,7 +34,7 @@ build() {
# build
npm run sencha:compile
- sed -i "s/require('electron-is-dev')/false/" 'build/production/Rambox/electron/main.js'
+ sed -i "s/require('electron-is-dev')/false/" "$srcdir/rambox-build/electron/main.js"
}
package() {