summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSergey M2019-11-04 00:43:47 +0300
committerSergey M2019-11-04 00:43:47 +0300
commit4752f7f58601d5201ceb5b93809d6ffae31e9a97 (patch)
tree7b460e4544017cf61ba7535fb0bef5690cea458b /PKGBUILD
parentfa8af3dc714626cad462942585333b7fb4afba42 (diff)
downloadaur-4752f7f58601d5201ceb5b93809d6ffae31e9a97.tar.gz
версия пакета берется из git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 7 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7db20fcf489f..91ab4f921bfe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,11 +10,18 @@ depends=('jq')
source=('git+https://github.com/tz4678/random-wallpaper.git')
md5sums=('SKIP')
+# https://wiki.archlinux.org/index.php/VCS_package_guidelines
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
package() {
cd "$srcdir/$pkgname"
install -Dm755 $pkgname $pkgdir/usr/bin/$pkgname
install -Dm644 $pkgname.service $pkgdir/usr/lib/systemd/system/$pkgname.service
install -Dm644 $pkgname.timer $pkgdir/usr/lib/systemd/system/$pkgname.timer
+ install -Dm644 $pkgname.conf $pkgdir/etc/conf.d/$pkgname
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -Dm644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
}