summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIgor Dyatlov2022-07-24 16:12:29 +0300
committerIgor Dyatlov2022-07-24 16:12:29 +0300
commitb3d38d7432aa8635d8fa3217b8c385af012ed476 (patch)
treeab3ebb2bef49551556ace8ba15786fb64777bfe7 /PKGBUILD
parent420e7514b08b1b91324031a3924c960e52a1c4e4 (diff)
downloadaur-b3d38d7432aa8635d8fa3217b8c385af012ed476.tar.gz
Updates
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4e6cd23bb0e9..f1893bf5c5f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
pkgname=randomgtk-git
_pkgname=random
-pkgver=r198.4f67b85
+pkgver=r363.2eecfb8
pkgrel=1
pkgdesc="A randomization app for GNOME"
-arch=('x86_64')
+arch=('x86_64' 'aarch64')
url="https://codeberg.org/foreverxml/random"
license=('AGPL3')
-depends=('glib2' 'gtk4' 'libadwaita' 'gdk-pixbuf2')
-makedepends=('git' 'meson' 'vala')
+depends=('libadwaita-git>=1.2.alpha')
+makedepends=('git' 'meson' 'gobject-introspection' 'vala')
checkdepends=('appstream-glib')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
@@ -29,6 +29,10 @@ build() {
meson compile -C build
}
+check() {
+ meson test -C build || :
+}
+
package() {
- DESTDIR="$pkgdir" meson install -C build
+ meson install -C build --destdir "$pkgdir"
}