summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorredfish2023-09-03 22:58:44 -0400
committerredfish2023-09-03 22:59:54 -0400
commit777feb1c7e0a1203f94724a74dbc8a9b09e5db19 (patch)
tree111f518afcc1c621744fd2522715a1967ea5e927 /PKGBUILD
parentcbfc64782cf09457490d537d256b6ba3ab4712ef (diff)
downloadaur-randomx.tar.gz
move cmake to prepare()
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ffa4825a06e7..e646585966ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=randomx
_name=RandomX
pkgver=1.1.10
-pkgrel=1
+pkgrel=2
pkgdesc="RandomX: The proof of work algorithm based on random code execution"
arch=('x86_64')
url="https://github.com/tevador/RandomX"
@@ -17,13 +17,15 @@ _blddir=build
prepare() {
cd "$srcdir/${_name}-${pkgver}"
patch -p1 -i ../include-cstdint.patch
+
+ mkdir -p ${_blddir}
+ cd ${_blddir}
+ cmake ..
}
build() {
cd "$srcdir/${_name}-${pkgver}"
- mkdir ${_blddir}
cd ${_blddir}
- cmake ..
make
}