summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDmytro Kostiuchenko2018-06-16 17:06:08 -0400
committerDmytro Kostiuchenko2018-06-16 17:10:03 -0400
commit00be7692a261044d456f4acc74448f4b109c7d16 (patch)
treea20f2d4226610cdff86683198c9270e39b2de94a /PKGBUILD
parent5fa71727dea188a5d75197237318fc517cb1dcb4 (diff)
downloadaur-00be7692a261044d456f4acc74448f4b109c7d16.tar.gz
Add bash completion to PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fcf45926cbb8..693ef4d68447 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,8 +11,14 @@ license=('GPLv3')
makedepends=('git' 'python-pip')
depends=('python' 'xorg-xrandr')
optdepends=('bash-completion')
-source=('git+https://github.com/edio/randrctl.git')
-md5sums=('SKIP')
+source=(
+ 'git+https://github.com/edio/randrctl.git'
+ 'completion'
+)
+md5sums=(
+ 'SKIP'
+ '0557733f74c7724ac0680e6166807b83'
+)
provides=("$_gitname")
conflicts=("$_gitname")
install="randrctl.install"
@@ -28,9 +34,8 @@ package() {
# PKGBUILD handles setup
python setup.py install --root="$pkgdir/" --optimize=1
- $pkgdir/usr/bin/randrctl setup completion > completion
- install -Dm644 completion "$pkgdir/usr/share/bash-completion/completions/randrctl"
- install -Dm644 randrctl/misc/udev/99-randrctl.rules "$pkgdir/usr/lib/udev/rules.d/99-randrctl.rules"
+ install -Dm644 "$srcdir/completion" "$pkgdir/usr/share/bash-completion/completions/randrctl"
+ install -Dm644 "randrctl/misc/udev/99-randrctl.rules" "$pkgdir/usr/lib/udev/rules.d/99-randrctl.rules"
}
# vim:set ts=2 sw=2 et: