summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkevku2015-08-12 16:35:07 +0300
committerkevku2015-08-12 16:35:07 +0300
commitfe72f72da93df5f85f27652b0b03c0b0c3140714 (patch)
tree077a22d3305c98a173d5d7a42edd55b6288163cd /PKGBUILD
downloadaur-fe72f72da93df5f85f27652b0b03c0b0c3140714.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f8e3af2730db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+pkgname=rar2fs
+pkgver=1.20.0
+pkgrel=5
+pkgdesc="Fuse file system for reading Rar archives"
+arch=("i686" "x86_64")
+license=("GPL3")
+url="https://hasse69.github.io/rar2fs/"
+
+# The "rar2fs" program loads the "libunrar" library at run time
+# using the exact version (5.m.n) installed at build time.
+# Also, the "libunrar" source code that "rar2fs" is built with
+# should probably be the same version that is installed.
+depends=("fuse" "libunrar")
+makedepends=("libunrar")
+
+source=( "https://github.com/hasse69/rar2fs/releases/download/v1.20.0/rar2fs-1.20.0.tar.gz"
+ "http://www.rarlab.com/rar/unrarsrc-5.2.7.tar.gz")
+sha256sums=('2b14cc5acefa12a07f5d0b1a4241713707e60e32f7a82cd86879ec1bd9cbae2d'
+ 'ef14757e943787b439fedf2c564c1f38d0db315528a928e0de170860717e2fac')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr --sbindir=/usr/bin --with-unrar=../unrar
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make install DESTDIR="$pkgdir"
+}
+