summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBenjamin Hedrich2017-01-31 22:19:53 +0100
committerBenjamin Hedrich2017-01-31 22:20:53 +0100
commitb5f265b7761de00c033fa1301b946dfe23b2852f (patch)
tree1ab2f750535690996e5f19827291b7c48654f47f /PKGBUILD
downloadaur-raspberry-remote-git.tar.gz
Intital commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5bf59ace407d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Benjamin Hedrich <code at pagenotfound.de>
+pkgname=raspberry-remote-git
+_gitname=raspberry-remote
+pkgver=70.8a5b705
+pkgrel=1
+pkgdesc="Control remote plugs with the Raspberry Pi, features a webinterface. Uses RCSwitch and wiringPi."
+url="https://github.com/xkonni/raspberry-remote"
+arch=('armv7h' 'armv6h' 'i686' 'x86_64')
+license=('GPL2')
+depends=('wiringpi-git')
+makedepends=('git')
+source=('git://github.com/xkonni/raspberry-remote')
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_gitname
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd $_gitname
+ make send
+}
+
+package() {
+ cd $_gitname
+ install -D send "${pkgdir}"/usr/bin/send
+}