summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChocobo12019-12-19 08:29:51 +0800
committerChocobo12019-12-19 08:29:51 +0800
commit49bfa6ba014514163f943d7e22067639d77d2dc1 (patch)
treef7f5ebbd04af45569f553dbc9cb456d5b46e035a /PKGBUILD
parentddcd657edea6a05605053d7a95608f3f6fb76cf8 (diff)
downloadaur-49bfa6ba014514163f943d7e22067639d77d2dc1.tar.gz
upgpkg: rav1e-git 0.2.0.r8.g5cbe7b83-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7577d6280f69..ef1501e99634 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=rav1e-git
-pkgver=r2149.944175b7
+pkgver=0.2.0.r8.g5cbe7b83
pkgrel=1
pkgdesc="The fastest and safest AV1 encoder"
arch=('i686' 'x86_64')
@@ -22,13 +22,16 @@ prepare() {
cd "rav1e"
# for librav1e
- RUSTFLAGS="-C opt-level=0" cargo install --root "$srcdir" cargo-c
+ RUSTFLAGS="-C opt-level=0" cargo install --force --root "$srcdir" cargo-c
}
pkgver() {
cd "rav1e"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ _tag=$(git tag -l --sort -v:refname | head -n1)
+ _rev=$(git rev-list --count $_tag..HEAD)
+ _hash=$(git rev-parse --short HEAD)
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's/v//'
}
check() {