summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJesse Luehrs2021-04-18 01:21:37 -0400
committerJesse Luehrs2021-04-18 01:21:37 -0400
commit6cb4d44af0a970776d4e004d38aa99f4c436115c (patch)
tree315044783257a712c289ce1e047a3b4ae65a85b5 /PKGBUILD
parentfc8d622c97aefba8111f63c8294f8c5f8e3ec1ae (diff)
downloadaur-6cb4d44af0a970776d4e004d38aa99f4c436115c.tar.gz
add shell completion files
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d60bb95b054e..c3b35fbd1605 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jesse Luehrs <archlinux@tozt.net>
pkgname=rbw
pkgver=1.2.0
-pkgrel=1
+pkgrel=2
makedepends=('rust' 'cargo')
depends=('pinentry' 'openssl')
conflicts=('rbw-git' 'rbw-bin')
@@ -16,6 +16,9 @@ license=('MIT')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
cargo build --release --locked
+ cargo run --release --locked --bin rbw -- gen-completions bash >bash-completions
+ cargo run --release --locked --bin rbw -- gen-completions zsh >zsh-completions
+ cargo run --release --locked --bin rbw -- gen-completions fish >fish-completions
}
check() {
@@ -28,4 +31,7 @@ package() {
install -Dm 755 target/release/rbw -t "${pkgdir}/usr/bin"
install -Dm 755 target/release/rbw-agent -t "${pkgdir}/usr/bin"
install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm 644 bash-completions "${pkgdir}/usr/share/bash-completion/completions/rbw"
+ install -Dm 644 zsh-completions "${pkgdir}/usr/share/zsh/site-functions/_rbw"
+ install -Dm 644 fish-completions "${pkgdir}/usr/share/fish/vendor_completions.d/rbw.fish"
}