summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKonstantinos2017-05-19 15:14:16 +0300
committerKonstantinos2017-05-19 15:14:16 +0300
commit79b2a374c8f84f5494628c2d16f7e953f0e4c37f (patch)
tree4d7ad0b6eb70202c619794615d904f090e3512b2 /PKGBUILD
downloadaur-79b2a374c8f84f5494628c2d16f7e953f0e4c37f.tar.gz
useful commit message
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1a9900c1dd1e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Konstantinos Foutzopoulos <mail@konfou.xyz>
+
+_pkgname=rc
+pkgname=${_pkgname}-rakitzis-git
+pkgver=r511.250c8ad
+pkgrel=1
+pkgdesc="Independent re-implementation for Unix of the Plan 9 shell."
+arch=('x86_64' 'i686')
+url="https://github.com/rakitzis/rc"
+license=('Custom:ISC')
+#depends=('')
+makedepends=('git')
+provides=("${_pkgname}")
+source=("git+https://github.com/rakitzis/${_pkgname}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${_pkgname}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd ${_pkgname}
+ autoreconf -i
+ #automake --add-missing
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${_pkgname}
+ install -Dm644 "COPYING" "${pkgdir}/usr/share/licenses/${_pkgname}-rakitzis"
+ make DESTDIR=${pkgdir} install
+}
+
+# vim:set ts=2 sw=2 et: \ No newline at end of file