summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorZhang Hua2023-02-17 20:37:46 +0800
committerZhang Hua2023-02-17 20:37:46 +0800
commita4eea3786ccc1ce1cc736ba8881a95a70d4dfd76 (patch)
tree0a16c29e58ce40b5bb2349e808aac0e83f7c4a43 /PKGBUILD
parentc86bf83e6ed09f99647592b6515a77c114e12042 (diff)
downloadaur-a4eea3786ccc1ce1cc736ba8881a95a70d4dfd76.tar.gz
Switch to upstream branch instead rebase manually
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 5 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 71d3f133099a..5aa32d3cab65 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Morten Linderud <foxboron@archlinux.org>
pkgname=rclone-aliyundrive-git
-pkgver=1.59.0.r93.gd3d843a11
+pkgver=1.59.0.beta.6199.08f5f7d56
pkgrel=1
pkgdesc="Rclone with aliyundrive support."
arch=("x86_64")
@@ -11,26 +11,18 @@ url="https://rclone.org/"
license=("MIT")
depends=("glibc")
optdepends=('fuse2: for rclone mount')
-makedepends=('python' 'pandoc' 'go' 'git' 'fuse2' 'git')
+makedepends=('python' 'pandoc' 'go' 'git' 'fuse2')
provides=("rclone")
conflicts=("rclone")
source=(
- "git+https://github.com/rclone/rclone.git"
- "aliyundrive-backend.patch"
- # Take and rebase from https://github.com/K265/rclone/tree/aliyundrive-backend
+ "git+https://github.com/K265/rclone.git#branch=aliyundrive-backend"
)
-sha256sums=('SKIP'
- '680f8f2cd08718fbd87dbf0bc069a423e4a336d7688c2d0ed8a15740e89ad4a4')
+sha256sums=('SKIP')
options=(!lto)
-prepare(){
- cd "${srcdir}/rclone"
- git apply "${srcdir}/aliyundrive-backend.patch"
- make tidy
-}
pkgver(){
cd "${srcdir}/rclone"
- git describe --tags --long | sed 's/v//;s/-/.r/;s/-/./g'
+ make version | sed 's/v//;s/.makepkg$//;s/-/./g'
}
build(){
cd "${srcdir}/rclone"