summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFritzOnFire2020-04-15 20:06:59 +0200
committerFritzOnFire2020-04-15 20:06:59 +0200
commit7fc66f00dccc81980eb0987bfce2b774e4d04fbb (patch)
tree442f9050fc4fca8ba6e37522f0d228d5786b1bd4 /PKGBUILD
parentbabafea5273a6231493617b4522da759c313d1d8 (diff)
downloadaur-7fc66f00dccc81980eb0987bfce2b774e4d04fbb.tar.gz
Adds support for linux 5.6
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 12 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7ca52f938619..4ce97c7201df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: foo <foo(at)example(dot)org>
# Contributor: bar <bar(at)example(dot)org>
-
+_kver=$(uname -r)
_pkgbase=rcraid
pkgname=rcraid-dkms
pkgver=17.2.1
@@ -15,16 +15,20 @@ makedepends=('linux-headers>=4.15')
# install=${pkgname}.install
source=('manual://raid_linux_driver_8_01_00_039_public.zip'
'dkms.conf'
- 'linux-4.15.patch')
+ 'linux-4.15.patch'
+ 'linux-5.4.patch'
+ 'linux-5.6.patch')
md5sums=('f5692d2ef952f8c903af90cdd9eb3ce6'
'3a14dcc84daf257a62727bcde1882edf'
- '461866e715a1fded49a3f7c043a173d7')
+ '461866e715a1fded49a3f7c043a173d7'
+ 'cac98de11cc5bd61fff72ff1c8cf363d'
+ 'bd1ef2b6bcefaec0abf7a832e937f01a')
prepare() {
if [ ! -d ${_pkgbase}-${pkgver} ]; then
mkdir ${_pkgbase}-${pkgver}
fi
-
+
cp driver_sdk/src/* ${_pkgbase}-${pkgver}
}
@@ -32,8 +36,10 @@ build() {
cd ${_pkgbase}-${pkgver}
patch -p1 -i "${srcdir}"/linux-4.15.patch
+ patch -p1 -i "${srcdir}"/linux-5.4.patch
+ patch -p1 -i "${srcdir}"/linux-5.6.patch
- make all
+ make KVERS="${_kver}" all
}
package() {
@@ -47,7 +53,7 @@ package() {
cd ${_pkgbase}-${pkgver}
- install -Dm644 rcraid.ko "${pkgdir}"/usr/lib/modules/$(uname -r)/kernel/drivers/scsi/rcraid.ko
+ install -Dm644 rcraid.ko "${pkgdir}"/usr/lib/modules/"${_kver}"/kernel/drivers/scsi/rcraid.ko
make clean
cp -r * "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}/