summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChloe Kudryavtsev2019-01-27 23:02:17 -0500
committerChloe Kudryavtsev2019-01-27 23:02:17 -0500
commit88daf3f61f2c09dfc00fa2cad030ece0a6cf42a5 (patch)
tree24451238e33367df8bab232cdf526be2ed6bb356 /PKGBUILD
parent0adc502f40c3fe5466351899ac8fdd6125902c38 (diff)
downloadaur-88daf3f61f2c09dfc00fa2cad030ece0a6cf42a5.tar.gz
Bump to 3.1.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dce0a570b5d1..8d96dbfb3f76 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,25 @@
-# Maintainer: Christoph S. <cadberry@mailbox.org>
+# Maintainer: Chloe K. <toast@toastin.space>
+# Contributor: Christoph S. <cadberry@mailbox.org>
# Contributor: Vlad M. <vlad@archlinux.net>
pkgname=rdedup
-pkgver=2.0.0
+pkgver=3.1.1
pkgrel=1
pkgdesc="Data deduplication engine, supporting optional compression and public key encryption"
url='https://github.com/dpc/rdedup'
-depends=('libsodium')
+depends=('libsodium' 'openssl')
makedepends=('cargo')
arch=('i686' 'x86_64')
license=('MPL')
-source=("$url/archive/v$pkgver/$pkgname-v$pkgver.tar.gz")
-sha256sums=('5be893fb82a8657b4a47474c429bbb95a7bec8a27f10b96948f52b61f10bdb81')
+source=("$url/archive/$pkgname-v$pkgver.tar.gz") # NOTE: weird release artifact
+sha256sums=('5e7c09c40897cd2f2635e8c213c2ff0f5c4d7ceccbd22980cd4cb0a16f3dfc28')
build() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname-$pkgname-v$pkgver"
RUSTFLAGS="-C target-cpu=native" cargo build --release
}
package() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname-$pkgname-v$pkgver"
install -Dm755 "target/release/$pkgname" "$pkgdir/usr/bin/$pkgname"
}