summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorxeruf2022-02-07 09:50:56 +0100
committerxeruf2022-02-07 09:50:56 +0100
commitc5b241de1b3b0c6c891256cfd8a448dc41261ca1 (patch)
tree611cb68c49fced91df7d3f2a0f79c8fb2431d8b0 /PKGBUILD
parentcd140ef1a9279c41158746a8f6671a9e5f6e8101 (diff)
downloadaur-rdictcc-git.tar.gz
Move to sourcehut and update description and maintainership
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 11 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cbbd41593aa7..eaa9576f7cb6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,27 @@
-# Maintainer: Jenya Sovetkin <e dot sovetkin at gmail dot com>
-pkgname=rdictcc-git
-pkgver=r36.43192fc
+# Maintainer: xeruf <27jf at pm dot me>
+
+_pkgname=rdictcc
+pkgname=${_pkgname}-git
+pkgver=r44.52f6b4b
pkgrel=1
-pkgdesc="A dictionary / word translator written in Ruby. It uses the dictionaries you can fetch from http://www.dict.cc. RDictCc has a tight integration into Emacs."
+pkgdesc="A Ruby translator using dictionary files from http://www.dict.cc, with tight Emacs integration"
arch=('any')
-url="https://github.com/tsdh/rdictcc"
+url="https://git.sr.ht/~tsdh/${_pkgname}"
license=('GPL3')
depends=('ruby' 'gdbm')
makedepends=('git')
-sha256sums=('SKIP')
-source=('git+git://github.com/tsdh/rdictcc.git')
-
-_gitroot=git://github.com/tsdh/rdictcc.git
-_gitname=rdictcc
+source=("git+${url}")
+sha512sums=(SKIP)
pkgver() {
- cd "${srcdir}/${_gitname}"
+ cd "${srcdir}/${_pkgname}"
# Get the version number.
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- cd "${srcdir}/${_gitname}"
+ cd "${srcdir}/${_pkgname}"
sed -i "s#-<>]/, ' ').strip.split do |w|#<>-]/, ' ').strip.split do#" rdictcc.rb
sed -i 's#rdictcc.rb#rdictcc#g' rdictcc.rb