summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAthemis2018-08-07 09:23:42 +0200
committerAthemis2018-08-07 09:23:42 +0200
commit2f41f0374c67df5f4fe9b35a81ce50c5f1dd2358 (patch)
tree8b98be0330437023126806f9b5cfece53f0a1864 /PKGBUILD
parent3607efff0de98cac0c3c455e9aed0d8674a84147 (diff)
downloadaur-2f41f0374c67df5f4fe9b35a81ce50c5f1dd2358.tar.gz
version bump; build fix with python 3.7
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c508c0eafeaa..557be173d9a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Samo Turk <samo.turk@gmail.com>
pkgname=rdkit
_pkgname=RDKit
-pkgver=2018_03_2
-pkgrel=4
+pkgver=2018_03_3
+pkgrel=1
pkgdesc="RDKit - A collection of cheminformatics and machine-learning software written in C++ and Python."
arch=("i686" "x86_64" "armv7h")
url="http://rdkit.org/"
license=('New BSD License')
depends=( 'bison' 'boost' 'boost-libs' 'cmake' 'flex' 'python' 'python-numpy' 'sqlite3' 'python-cairocffi' 'python-pillow' 'inchi' 'eigen3' )
source=("https://github.com/rdkit/rdkit/archive/Release_${pkgver}.tar.gz")
-sha256sums=('29eeba93e723f0f9d61e31cf0f89ec18ba942a7f9e416dbc1a92122fce08cbed')
+sha256sums=('f8577a8f46dcc140acf3bcd3a2f50ba3e1a333d0f24b52d63832c96754b2bb1f')
conflicts=('rdkit-python2' 'rdkit-git')
build() {
@@ -18,8 +18,8 @@ build() {
-DCMAKE_BUILD_TYPE=Release \
-DRDK_INSTALL_INTREE=0 \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.6m.so \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.6m/ \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m/ \
-DPYTHON_EXECUTABLE=/usr/bin/python \
-DRDK_BUILD_INCHI_SUPPORT=ON
make