summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlemust832015-06-09 13:28:38 +0200
committerlemust832015-06-09 13:28:38 +0200
commit26d2f3f599c9af94441c0b7701e2937003e6c1f4 (patch)
tree42f76eafb8c0ffbcb997272b6212d13c43230564 /PKGBUILD
downloadaur-26d2f3f599c9af94441c0b7701e2937003e6c1f4.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..1064248f7257
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+ # Maintainer: lemust83 <lemust83420@gmail.com>
+ pkgname=readesm-fr
+ pkgver=2.4
+ pkgrel=1
+ pkgdesc="lire les fichiers Tachographs issus de Cardpeek ou autres dans un format humainement compréhensible"
+ arch=(i686 x86_64)
+ url="http://readesm.sourceforge.net/help.html"
+ license=('GPL')
+ groups=()
+ depends=('boost' 'gmp' 'libgcrypt' 'qt4' 'qtwebkit' 'python2')
+ makedepends=('cmake')
+ replaces=('readesm' 'readesm-fr' )
+ source=(http://switch.dl.sourceforge.net/project/readesmfr/readesm-fr/readesm-fr.2.4.tar.gz)
+ sha256sums=(e4a016d3654646f4bb4cc5e1fc708e2208ff8efa6bcfc588d61d498165167412)
+
+ build() {
+ cd "$srcdir/readesm-fr.2.4/fileformat"
+ python2 ./generate.py
+ cd ..
+ mkdir build
+ cd build
+ cmake ..
+ make
+ }
+
+ package ()
+ {
+ cd "$srcdir/readesm-fr.2.4/build"
+ make DESTDIR="$pkgdir" install
+ }