summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGoliathLabs2020-06-22 14:29:35 +0200
committerGoliathLabs2020-06-22 14:29:35 +0200
commit0bc6d7202b4ca3ab6f97997d66b64e6c3a7a0088 (patch)
treee1da2f732fe3241579ce36d0780c0ede19bd2d1c /PKGBUILD
parent9cbbc41a909e7bcfcb994cb045cbe223acacc561 (diff)
downloadaur-0bc6d7202b4ca3ab6f97997d66b64e6c3a7a0088.tar.gz
Updated: PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 22 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9e9328e191e7..acdb999a66b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,17 +4,24 @@
_pkgname=realmd
pkgname=$_pkgname-git
pkgver=0.16.3.r35.g517fa76
-pkgrel=1
-pkgdesc="DBus service for joining hosts to Active Directory and FreeIPA realms"
+pkgrel=2
+pkgdesc="DBus service for joining hosts to Active Directory and FreeIPA realms (Git)"
arch=(i686 x86_64)
url="https://freedesktop.org/software/realmd/"
license=(GPL3)
depends=(adcli dbus krb5 openldap packagekit polkit)
+optdepends=('sssd: Active Directory, FreeIPA, LDAP client'
+ 'samba: traditional Active Directory client')
makedepends=(docbook-xsl git intltool python xmlto)
-provides=("$_pkgname=$pkgver")
-conflicts=("$_pkgname")
-source=("git+https://gitlab.freedesktop.org/realmd/realmd.git")
-sha256sums=('SKIP')
+source=("git+https://gitlab.freedesktop.org/realmd/realmd.git"
+ computer-ou.patch
+ duplicate-test-path.patch
+ install-diagnostic.patch)
+sha256sums=('SKIP'
+ '5e43d034348bdf3cb3f06ebd56d811b3427e43f9220fee9a104f50d3972cb5cd'
+ 'a659dfcf8e4f91123832ae89b9ac92bbcc9ea8d90a698533ca25dff9ec610d90'
+ 'e49fc613594d4fb540f0a562778e2fd45711548cbe3dc9769f5aa0773de16319')
+validpgpkeys=('C0F67099B808FB063E2C81117BFB1108D92765AF')
pkgver() {
cd "$_pkgname"
@@ -23,12 +30,20 @@ pkgver() {
prepare() {
cd "$_pkgname"
+ local src
+ for src in "${source[@]}"; do
+ src="${src%%::*}"
+ src="${src##*/}"
+ [[ $src = 0*.patch ]] || continue
+ echo "Applying patch $src..."
+ patch -Np1 < "../$src"
+ done
AUTOMAKE=automake ACLOCAL=aclocal NOCONFIGURE=1 ./autogen.sh
}
build() {
cd "$_pkgname"
- ./configure \
+ AUTOMAKE=automake ACLOCAL=aclocal ./configure \
--prefix=/usr \
--sbindir=/usr/bin \
--sysconfdir=/etc \