summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMantas Mikulėnas2017-09-16 14:02:43 +0300
committerMantas Mikulėnas2017-09-16 14:02:43 +0300
commit4f29f730a22eeda2488e8551c4f3052c0251573e (patch)
treef27d400d602bb3a2ee91e5502ee51d09b7f97b06 /PKGBUILD
parent95ca051856977aa40a3714011fd29e39e0b5fd87 (diff)
downloadaur-4f29f730a22eeda2488e8551c4f3052c0251573e.tar.gz
implement check()
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 12 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1c7279a99315..f86a93af1279 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,8 @@ arch=(i686 x86_64)
url="http://freedesktop.org/software/realmd/"
license=(GPL3)
depends=(adcli dbus krb5 openldap packagekit polkit)
-makedepends=(docbook-xsl intltool python2 xmlto)
+makedepends=(docbook-xsl intltool xmlto)
+checkdepends=(python2)
provides=("$_pkgname=$pkgver")
conflicts=("$_pkgname")
source=("git://anongit.freedesktop.org/realmd/$_pkgname")
@@ -19,6 +20,11 @@ pkgver() {
git describe | sed 's/-/.r/; s/-/./g'
}
+prepare() {
+ cd "$_pkgname"
+ sed -i '1s/\<python\>/&2/' build/tap-*
+}
+
build() {
cd "$_pkgname"
NOCONFIGURE=1 ./autogen.sh
@@ -31,6 +37,11 @@ build() {
make
}
+check() {
+ cd "$_pkgname"
+ make check
+}
+
package() {
cd "$_pkgname"
make DESTDIR="$pkgdir" install