summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorderwinlu2015-06-30 07:47:46 +0200
committerderwinlu2015-06-30 07:47:46 +0200
commit152c53eb0a87252b1f57233f511eae488a600440 (patch)
treecd795ce37cc9c7989c41051e499972d6f6bb1d54 /PKGBUILD
downloadaur-152c53eb0a87252b1f57233f511eae488a600440.tar.gz
Port from aur3 to aur4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..970b23492a98
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# $Id$
+# Maintainer: winlu <derwinlu@gmail.com>
+
+pkgname=rebar3
+_pkgver=alpha-6
+pkgver=${_pkgver//-/_}
+pkgrel=1
+pkgdesc="A sophisticated build-tool for Erlang projects that follows OTP principles."
+arch=('any')
+url="https://github.com/rebar/rebar3"
+license=('APACHE')
+depends=('erlang-nox')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/rebar/rebar3/archive/${_pkgver}.tar.gz")
+md5sums=('ab18b1149294257cfaac3826b5c34eda')
+
+build() {
+ cd "$srcdir/$pkgname-$_pkgver"
+ ./bootstrap
+}
+
+package() {
+ cd "$srcdir/$pkgname-$_pkgver"
+ install -Dm0755 "${pkgname}" "$pkgdir/usr/bin/${pkgname}"
+ install -Dm0644 "priv/shell-completion/bash/rebar3" "$pkgdir/usr/share/bash-completion/completions/rebar3"
+}