summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkpcyrd2020-09-11 03:31:12 +0200
committerkpcyrd2020-09-11 03:31:12 +0200
commitc24c74557e777b1ef51b0c6b8b54d99807014062 (patch)
treea58161b33d72b4994978e23f3908d16b7a7ca12b /PKGBUILD
parent2ce1fb05c6e31a2e9cddabc3fd34770dd6543ee9 (diff)
downloadaur-c24c74557e777b1ef51b0c6b8b54d99807014062.tar.gz
v5.1.1-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 9 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7eddfc122536..af5f1d8e2ef3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,21 @@
# Maintainer: kpcyrd <git@rxv.cc>
pkgname=recon-ng
-pkgver=4.9.6
+pkgver=5.1.1
pkgrel=1
pkgdesc='A full-featured Web Reconnaissance framework written in Python'
-url='https://bitbucket.org/LaNMaSteR53/recon-ng'
+url="https://github.com/lanmaster53/recon-ng"
license=('GPL3')
arch=('any')
-depends=('python2' 'python2-dicttoxml' 'python2-dnspython'
- 'python2-jsonrpclib-pelix'
- 'python2-lxml' 'python2-mechanize' 'python2-slowaes'
- 'python2-xlsxwriter' 'python2-olefile' 'python2-pypdf2'
- 'python2-flask' 'python2-unicodecsv')
-source=(${pkgname}-${pkgver}.tar.gz::https://bitbucket.org/LaNMaSteR53/recon-ng/get/v${pkgver}.tar.gz
+depends=('python' 'python-pyaml' 'python-dnspython' 'python-lxml' 'python-mechanize'
+ 'python-requests' 'python-flask' 'python-flask-restful' 'python-flasgger'
+ 'python-dicttoxml' 'python-xlsxwriter' 'python-unicodecsv' 'python-rq')
+source=("https://github.com/lanmaster53/${pkgname}/archive/v${pkgver}/recon-ng-${pkgver}.tar.gz"
opt-in-analytics.patch)
-sha256sums=('0192a9882bb9800f2177fcdb31cda8031bbc3895db9fe4a0966ebdd771b66915'
- '3208e111fb44e0799272429b6d87544a2a54a6f48ef640524a19a8c0a37d3d00')
+sha256sums=('470e293e931c23a0dc76e6915098e04db7f2e254a0639bb2c0383e0758c4fbc2'
+ '72d1e10a2b4bdbacb85bc8d3b430e406fc0ec5b7bf5cad85476cd29281053385')
prepare() {
- rm -rf "recon-ng-${pkgver}"
- mv LaNMaSteR53-recon-ng-* "recon-ng-${pkgver}"
cd "${pkgname}-${pkgver}"
# change analytics from opt-out to opt-in
patch -Np1 -i ../opt-in-analytics.patch
@@ -36,7 +32,7 @@ package() {
cat > "${pkgdir}/usr/bin/${bin}" << EOF
#!/bin/sh
cd /opt/recon-ng
-exec python2 ${bin} "\$@"
+exec python ${bin} "\$@"
EOF
chmod +x "${pkgdir}/usr/bin/${bin}"
done