summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStefan Haller2020-03-12 22:34:13 +0100
committerStefan Haller2020-03-12 22:37:15 +0100
commitd2a265f0ce81405e4fd22eec2c5d83a3b4ce2534 (patch)
tree92540e9957100648ac3503b36ac09a00885ee033 /PKGBUILD
parentcb914543e7bd98f92ab54a493b6077ef695740b9 (diff)
downloadaur-d2a265f0ce81405e4fd22eec2c5d83a3b4ce2534.tar.gz
Remove --with-bash-headers and add checkdepends
The option `--with-bash-headers` seems to not work as intended, but prevents bash built-in completion. The package `check` is needed to run the tests.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1b54899b8025..b3cc04505317 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
# Maintainer: Stefan Haller <fgrsnau@gmail.com>
pkgname=recutils
pkgver=1.8
-pkgrel=1
+pkgrel=2
pkgdesc="Set of tools and libraries to access plain text databases called recfiles."
arch=(i686 x86_64)
url="https://www.gnu.org/software/recutils/"
license=('GPL')
depends=('libgcrypt')
+checkdepends=('check')
source=("https://ftp.gnu.org/gnu/recutils/$pkgname-$pkgver.tar.gz")
md5sums=('0ec4f9046cc01092758be9c4988c6fb3')
build() {
cd "$pkgname-$pkgver"
- ./configure --prefix=/usr --with-bash-headers
+ ./configure --prefix=/usr
make
}