summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStefan Haller2015-12-05 14:12:05 +0100
committerStefan Haller2015-12-05 14:12:05 +0100
commitda891b47704881634878937c7a2ba002a553e57c (patch)
treec09d68c5080f411143a629c6adb0c34a1f7f80c2 /PKGBUILD
downloadaur-da891b47704881634878937c7a2ba002a553e57c.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..65ea96758201
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Stefan Haller <fgrsnau@gmail.com>
+pkgname=recutils
+pkgver=1.7
+pkgrel=1
+pkgdesc="Set of tools and libraries to access plain text databases called recfiles."
+arch=(i686 x86_64)
+url="https://www.gnu.org/software/recutils/"
+license=('GPL')
+depends=('libgcrypt')
+source=("https://ftp.gnu.org/gnu/recutils/$pkgname-$pkgver.tar.gz")
+md5sums=('187e90421cdf69ce649876324a20b452')
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ make -k check
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}