summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonian Guveli2020-05-06 17:17:26 +0300
committerJonian Guveli2020-05-06 17:17:26 +0300
commitdb8dd6c728ad31ecb8549648880f806d03466b8d (patch)
treef5a2553d7c0778b38edcfd1fb2999bd9253e8738 /PKGBUILD
parentf88fed4ea9ef1dbb346e75286493a41ed3de37a4 (diff)
downloadaur-db8dd6c728ad31ecb8549648880f806d03466b8d.tar.gz
fix build error
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dd67b607d022..6a1e67b13fd4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jonian Guveli <https://github.com/jonian/>
pkgname=redi-search
pkgver=1.6.12
-pkgrel=1
+pkgrel=2
pkgdesc="Redis module that implements a search engine on top of Redis."
arch=("x86_64")
url="https://github.com/RediSearch/RediSearch"
@@ -12,18 +12,18 @@ source=("$pkgname-$pkgver::git+$url")
md5sums=("SKIP")
prepare() {
- cd "$pkgname"
+ cd "$pkgname-$pkgver"
git checkout tags/v$pkgver
git submodule update --init
}
build() {
- cd "$pkgname"
+ cd "$pkgname-$pkgver"
make
}
package() {
- cd "$pkgname"
+ cd "$pkgname-$pkgver"
install -D src/redisearch.so $pkgdir/usr/lib/redis/redisearch.so
install -Dm644 LICENSE $pkgdir/usr/share/licenses/redisearch/LICENSE
}