summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonian Guveli2020-04-29 01:50:39 +0300
committerJonian Guveli2020-04-29 01:50:39 +0300
commite54ea98ed7664dae2e384a8463159d3ccd257124 (patch)
treeb602b72f916601016fac70d22ed3feb1787c4667 /PKGBUILD
downloadaur-e54ea98ed7664dae2e384a8463159d3ccd257124.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f168aec66350
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Jonian Guveli <https://github.com/jonian/>
+pkgname=redi-search
+pkgver=1.6.12
+pkgrel=1
+pkgdesc="Redis module that implements a search engine on top of Redis."
+arch=("x86_64")
+url="https://github.com/RediSearch/RediSearch"
+license=("Custom")
+depends=("redis")
+makedepends=("git" "cmake")
+source=("$pkgname::git+$url")
+md5sums=("SKIP")
+
+prepare() {
+ cd "$pkgname"
+ git checkout tags/v$pkgver
+ git submodule update --init
+}
+
+build() {
+ cd "$pkgname"
+ make
+}
+
+package() {
+ cd "$pkgname"
+ install -D src/redisearch.so $pkgdir/usr/lib/redis/redisearch.so
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/redisearch/LICENSE
+}