summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLeo P2016-05-10 15:53:32 -0400
committerLeo P2016-05-10 15:53:32 -0400
commitba4b3b94f0c5259b7c3e51a32638b385f8337b16 (patch)
tree9fa24990707841a79fc9fff312b7259aae31f93b /PKGBUILD
downloadaur-ba4b3b94f0c5259b7c3e51a32638b385f8337b16.tar.gz
redis-git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a9a250e80b82
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# $Id: PKGBUILD 159813 2016-02-01 18:34:51Z spupykin $
+
+pkgname=redis-git
+provides=('redis')
+conflicts=('redis')
+pkgver=r5692.646c958
+pkgrel=1
+pkgdesc='Advanced key-value store (git unstable branch)'
+arch=('i686' 'x86_64')
+url='http://redis.io/'
+license=('BSD')
+depends=('jemalloc' 'grep' 'shadow')
+backup=('etc/redis.conf'
+ 'etc/logrotate.d/redis')
+install=redis.install
+source=(git+https://github.com/antirez/redis.git#branch=unstable
+ redis.service
+ redis.logrotate
+ redis.conf-sane-defaults.patch
+ redis-2.8.11-use-system-jemalloc.patch)
+md5sums=('SKIP'
+ 'afa0f4a9000c26c3323e83fe34883e23'
+ '9e2d75b7a9dc421122d673fe520ef17f'
+ '990536d339b694d76415ec1e847b861a'
+ '2ae176578f538e37a67a463258302bc6')
+
+pkgver() {
+ cd redis
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd redis
+ patch -p1 -i ../redis.conf-sane-defaults.patch
+ patch -p1 -i ../redis-2.8.11-use-system-jemalloc.patch
+}
+
+build() {
+ make -C redis
+}
+
+package() {
+ cd redis
+ make PREFIX="$pkgdir"/usr install
+
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/redis/LICENSE
+ install -Dm644 redis.conf "$pkgdir"/etc/redis.conf
+ install -Dm644 ../redis.service "$pkgdir"/usr/lib/systemd/system/redis.service
+
+ # files kept for compatibility with installations made before 2.8.13-2
+ install -Dm644 ../redis.logrotate "$pkgdir"/etc/logrotate.d/redis
+
+ ln -sf redis-server $pkgdir/usr/bin/redis-sentinel
+}