summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKaizhao Zhang2021-03-13 01:29:18 +0800
committerKaizhao Zhang2021-03-13 01:29:18 +0800
commitd51b2c59fcb5cc4bf6b25b437e1ca06ba005ef78 (patch)
tree08de04cfb6cbb2cfb9a518905acf7cfb09523248 /PKGBUILD
parentff618a2d129e75280bdd0c0be570e53bbc871b53 (diff)
downloadaur-d51b2c59fcb5cc4bf6b25b437e1ca06ba005ef78.tar.gz
Updated to version 0.10.4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 697d71b35f9a..d9c03dde8f9e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Kaizhao Zhang <zhangkaizhao@gmail.com>
pkgname=redoc-cli
-pkgver=0.9.13
+pkgver=0.10.4
pkgrel=1
pkgdesc="ReDoc's Command Line Interface"
arch=('any')
@@ -13,13 +13,15 @@ source=(
"https://registry.npmjs.org/${pkgname}/-/${pkgname}-${pkgver}.tgz"
)
sha256sums=(
- '132e5abeae1da812f044abe4da2ae8389f33cd346ebb9ae28e5e3b78b615fc82'
+ 'b0baae4b1d21d4a46cfea5e69b4e9c72bcda9da89b6c428fad6747f57dd0b8c1'
)
noextract=("${pkgname}-${pkgver}.tgz")
package() {
npm install -g --user root --prefix "${pkgdir}/usr" "${srcdir}/${pkgname}-${pkgver}.tgz"
chmod -R go-w "${pkgdir}/usr"
+ # Why there is always a weird package `/usr/lib/node_modules/root/` while installing some packages from npm?
+ rm -rf "${pkgdir}/usr/lib/node_modules/root/"
}
# vim:set ts=2 sw=2 et: