summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBranislav Holý2016-02-11 00:44:39 +0100
committerBranislav Holý2016-02-11 00:44:39 +0100
commit414adfa9e23afd84705e4f96e2e4e7a8ff7d7a5a (patch)
treeb354fc6ceb431fb2e63c163c0060dbdbcf4f4b56 /PKGBUILD
parent6330dfacff8763ef4a30b159a2d49740bff80e63 (diff)
downloadaur-414adfa9e23afd84705e4f96e2e4e7a8ff7d7a5a.tar.gz
New upstream version.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 18 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b10871f4348d..e5e78a4d079a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,34 @@
+# Generated by pakanton
# Maintainer: Branislav Holý <branoholy@gmail.com>
pkgname=regilo
-pkgver=2.1.1
+pkgver=2.1.2
pkgrel=1
pkgdesc="A simple C++ library for controlling the Neato XV robot and the Hokuyo scanner"
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
-url="https://github.com/branoholy/$pkgname"
+url="https://github.com/branoholy/regilo"
license=('GPL3')
-depends=('boost>=1.54')
makedepends=('cmake>=2.8')
-source=("https://github.com/branoholy/$pkgname/archive/v$pkgver/$pkgname-$pkgver.tar.gz"
- "https://github.com/branoholy/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz.sig")
-md5sums=('207846f917b6a5cf9fe813f8b238e24f'
- 'c51f41989aeda3272ae42b987513071b')
-sha1sums=('8d681ab065ebff69846566372185514b53cbbf00'
- 'ff70a2502104ea0a22757ed34fa0737d61b868cc')
-sha256sums=('f62f0507d16e4c07fb8f5e8625e550f15334c5820ad8df28e7705607b312994d'
- 'df4facc9a1b6f85d5ca376356b41dad822300a59c6dc87526f84abcfdeb90add')
-sha512sums=('6016c55ca48bdf1e3a0726b041fa89a82c6f1a8327df0431c3d8cdbb2000b7a0e28ae04886ec463c4133df72993f5c15f59c2f23b087772b8a1095c31f664f62'
- 'cfd97819334ed19e8af1d340da4cba20a8b94272464aa24a8b086bfe1a6318e162d552059fe63b069f709599d820b89a6f5c5357be1fb178231ffc5f8fae1ff2')
+depends=('boost>=1.54' 'regilo-lib=2.1.2')
+source=("https://github.com/branoholy/regilo/archive/v$pkgver/regilo-$pkgver.tar.gz"
+ "https://github.com/branoholy/regilo/releases/download/v$pkgver/regilo-$pkgver.tar.gz.sig")
+md5sums=('7c5d000f138d1523dfa212674d3205a0'
+ '2b574dd8fc1fcd7d771e1eb90d4f17e5')
+sha1sums=('ba7328ad64267dec90aac4b79c7da877c3f0d1bb'
+ 'fd00e64f4248dc953a9983021239111349a57406')
+sha256sums=('08054d813902df333427ee3822a430f67b99987048fdf3dd737d2c4027b45b00'
+ 'e3ea6fb7d6e2eaa01595aa29b4d17dad342d3834ec0d510cec54d9e1eb9b5f67')
+sha512sums=('2d177ccbe81ef38804912b3d06f44bc32465093d8d936fba9e38dfc1a94d6485175b7d1ffb3e130d803a56e6221b6dd4af96c52f64339207c48613378c9127b3'
+ '195a53032818f003fd0276fe1666bd73e10b8f28c52ef8219c608012c8ce4ba0c8ec9adac8b834eda3b35e61d68269f4bed6c182932997e2a1841915c62350a3')
validpgpkeys=('D25809BF3563AA56A12B0F4D545EDD46FBAC61E6')
build() {
- cd "$pkgname-$pkgver"
- mkdir -p build
- cd build
- cmake -Dexample:bool=on -DCMAKE_INSTALL_PREFIX=/usr ..
+ cd $pkgname-$pkgver
+ mkdir -p build && cd build
+ cmake -Dheaders-only:bool=on -Dexample:bool=on -DCMAKE_INSTALL_PREFIX=/usr ..
make
}
package() {
- cd "$pkgname-$pkgver"
- cd build
+ cd $pkgname-$pkgver/build
make DESTDIR="$pkgdir/" install
}