summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaxime Gauduin2018-08-13 11:46:37 +0200
committerMaxime Gauduin2018-08-13 11:46:37 +0200
commit364ca0fda0510bf8308be9d5c9d0640990c94e90 (patch)
tree5618cd2b3f1ac6740aa21ed9f955fee67d91c2b5 /PKGBUILD
parent225cb232fe33c1d8705db630062ee8771ba9f533 (diff)
downloadaur-364ca0fda0510bf8308be9d5c9d0640990c94e90.tar.gz
reicast r7-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 7 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9ce39c21831f..372c159e929c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,23 @@
# Maintainer: carstene1ns <archi@carsten-teibes.de>
pkgname=reicast
-pkgver=r7_rc1
+pkgver=r7
pkgrel=1
pkgdesc='A Sega Dreamcast emulator'
arch=('x86_64')
url='http://reicast.com/'
license=('GPL2')
-depends_i686=('alsa-lib' 'libgl')
-depends_x86_64=('lib32-alsa-lib' 'lib32-libgl' 'lib32-alsa-lib')
-source=("reicast-${pkgver/_/-}.tar.gz::https://github.com/reicast/reicast-emulator/archive/${pkgver/_/-}.tar.gz")
-sha256sums=('f2ff9695ab04cedfee3446af5c6ab98b7e2d08f55726dde757fdfbbe88df8355')
+depends=('alsa-lib' 'libgl')
+makedepends=('git')
+source=("git+https://github.com/reicast/reicast-emulator.git#tag=${pkgver}")
+sha256sums=('SKIP')
build () {
- cd reicast-emulator-${pkgver/_/-}/shell/lin86
-
- make
+ make -C reicast-emulator/shell/linux
}
package () {
- cd reicast-emulator-${pkgver/_/-}/shell/lin86
-
- install -dm 755 "${pkgdir}"/usr/bin
- install -m 755 reicast.elf "${pkgdir}"/usr/bin/reicast
+ install -Dm 755 reicast-emulator/shell/linux/reicast.elf "${pkgdir}"/usr/bin/reicast
}
# vim: ts=2 sw=2 et: