summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarsten Teibes2021-01-17 14:48:56 +0100
committerCarsten Teibes2021-01-17 14:48:56 +0100
commit3595370c37a2c6e7bdc1f902fdca733670184221 (patch)
treed1880bf589f889405923ca78393c2205c55a924f /PKGBUILD
parentf3ffb814e70a39343d08a9bd4400a8a34f5b9562 (diff)
downloadaur-3595370c37a2c6e7bdc1f902fdca733670184221.tar.gz
[upd] new dependency, [fix] change directory
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9e074a7b9fd6..879e441e097f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,33 @@
# Contributor: Holzhaus <jan.holthuis@ruhr-uni-bochum.de>
pkgname=reicast-git
-pkgver=r1633.1a751e3
+pkgver=20.04.r48.g0bd6ea371
pkgrel=1
pkgdesc="A multiplatform Sega Dreamcast emulator (development version)"
arch=('i686' 'x86_64' 'armv7h')
url="http://reicast.com/"
-license=('GPL2' 'BSD' 'MIT')
+license=('custom')
conflicts=('reicast')
provides=('reicast')
makedepends=('git')
-depends=('libgl' 'alsa-lib')
+depends=('libgl' 'alsa-lib' 'libpulse')
+optdepends=('python: for joystick configuration utility')
source=(reicast::"git+https://github.com/reicast/reicast-emulator.git")
md5sums=('SKIP')
pkgver() {
cd reicast
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long | sed 's/^r//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build () {
- make -C reicast/shell/linux PREFIX=/usr
+ USE_PULSEAUDIO=1 make -C reicast/reicast/linux PREFIX=/usr
}
package () {
- make -C reicast/shell/linux DESTDIR="$pkgdir/" PREFIX=/usr install
+ cd reicast
+ make -C reicast/linux DESTDIR="$pkgdir/" PREFIX=/usr install
+ # licenses
+ install -d "$pkgdir"/usr/share/licenses/$pkgname
+ install -m644 LICENSE* "$pkgdir"/usr/share/licenses/$pkgname/
}