summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarsten Teibes2015-07-21 16:35:37 +0200
committerCarsten Teibes2015-07-21 16:35:37 +0200
commitece97b1a100cad54fc85a6fe79fb18f6b5db0a69 (patch)
treeb87dd76e35bde8670e4aba9ccb7235c007671ba1 /PKGBUILD
parentb363391f0211fe7055dd0ba5cb2f8b72ad9b4cb3 (diff)
downloadaur-ece97b1a100cad54fc85a6fe79fb18f6b5db0a69.tar.gz
[upd] Allow native x86_64 building
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ad7340af04ba..bff3660c57d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
pkgname=reicast-git
-pkgver=r1200.a9fc0f5
+pkgver=r1252.5b92793
pkgrel=1
pkgdesc="A multiplatform Sega Dreamcast emulator (development version)"
arch=('i686' 'x86_64')
@@ -10,8 +10,7 @@ license=('GPL2' 'BSD' 'MIT')
conflicts=('reicast')
provides=('reicast')
makedepends=('git')
-depends_x86_64=('lib32-libgl' 'lib32-alsa-lib')
-depends_i686=('libgl' 'alsa-lib')
+depends=('libgl' 'alsa-lib')
source=(reicast::"git+https://github.com/reicast/reicast-emulator.git")
md5sums=('SKIP')
@@ -21,13 +20,13 @@ pkgver() {
}
build () {
- make -C reicast/shell/lin86
+ make -C reicast/shell/lin${CARCH: -2}
}
package () {
cd reicast
- install -Dm755 shell/lin86/reicast.elf "$pkgdir"/usr/bin/reicast
+ install -Dm755 shell/lin${CARCH: -2}/reicast.elf "$pkgdir"/usr/bin/reicast
# license
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}