summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichal2015-10-27 19:45:17 +0000
committerMichal2015-10-27 19:45:17 +0000
commiteef9bcc5aad8d9e976d29a8fad29982c5271df6b (patch)
tree53356b755fbfec85d2eceb0a5d45dbd187cad4b6 /PKGBUILD
downloadaur-eef9bcc5aad8d9e976d29a8fad29982c5271df6b.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d39cdea6fcf7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Michal Lisowski <lisu87@gmail.com>
+pkgname=relevation
+pkgver=1.3
+pkgrel=1
+pkgdesc="Command-line search for Revelation Password Manager files"
+arch=('any')
+url="http://p.outlyer.net/relevation/"
+license=('custom')
+depends=('python2-crypto' 'python2-lxml')
+makedepends=('python2-setuptools')
+source=("http://p.outlyer.net/relevation/files/relevation-1.3.tar.gz"
+ "$pkgname-python2.patch")
+md5sums=('4b5ec6152c7c6a26f4aa3e1f157ef4e3'
+ 'a020e1a4f8aeb056f2335224ed3ee3c7')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch -p1 -i "$srcdir/$pkgname-python2.patch"
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make prefix=/usr DESTDIR="$pkgdir/" install
+
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}