summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMikael Blomstrand2018-03-03 21:00:06 +0100
committerMikael Blomstrand2018-03-03 21:00:06 +0100
commit4fe3b6d3ff393303f186a404a71308b3664fef02 (patch)
treef8f0e245891276f0580b348e51b286b3423648e9 /PKGBUILD
parent263b3f3dd31583eb506f6dc119eb0153f0eced2a (diff)
downloadaur-4fe3b6d3ff393303f186a404a71308b3664fef02.tar.gz
Patched to use webkit2gtk.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD65
1 files changed, 37 insertions, 28 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fa45f4417f79..6936e7b547ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,13 @@
-# Maintainer: Michael Goehler <somebody dot here at gmx dot de>
+# Maintainer: Mikael Blomstrand <gmail: chawlindel>
# Contributor: MaryJaneInChain <gmail.com@maryjaneinchain>
+# Contributor: Michael Goehler <somebody dot here at gmx dot de>
pkgname=remarkable
+replaces=('remarkable-webkit2gtk')
pkgver=1.87
-pkgrel=1
+pkgrel=2
pkgdesc="A free fully featured markdown editor for Linux."
-arch=('i686' 'x86_64')
+arch=('any')
url="http://remarkableapp.github.io"
license=('MIT')
depends=('python'
@@ -15,43 +17,50 @@ depends=('python'
'python-beautifulsoup4'
'python-gtkspellcheck'
'python-lxml'
- 'webkitgtk'
+ 'webkit2gtk'
'wkhtmltopdf'
'gtksourceview3'
)
makedepends=('python')
optdepends=('python-lxml: export to HTML format support')
-options=('!emptydirs' '!strip')
-install="${pkgname}.install"
-source=("${pkgname}_${pkgver}_all.deb::http://remarkableapp.github.io/files/${pkgname}_${pkgver}_all.deb"
- "${pkgname}.install")
-md5sums=('b14b7bf5b4d4cbf2acb9559220bba982'
- '4230de2876e8789bcd5a7cdc84b2a30b')
+
+install="remarkable.install"
+source=("https://github.com/jamiemcg/Remarkable/archive/v${pkgver}.tar.gz"
+ "0003-fixes-184-port-to-WebKit2Gtk.patch"
+ "0004-fixes-175-Live-Preview-Mode-Executes-JavaScript.patch"
+ "remarkable.patch"
+ "remarkable.install"
+ "LICENSE")
+
+sha1sums=('a492dc5d0a276f36846a99287ae93c02e22a5cd8'
+ '097f12a6f499bd39b99c32301a9027a9457eaeac'
+ 'd90a26e2830f0306a07b76dc69aa211840f0223e'
+ 'd9fc74c5a0136649f670a345e16c1c88d21a97d2'
+ 'bdbfb750df9e5fb3022f47a46a80555259628cd1'
+ '6e5ea06076c85fdd25b79bfc41588f7f7ee9ba29')
+
+prepare() {
+ msg2 "Applying patches for webkit2gtk..."
+ cat *.patch | patch -p1 -d "${srcdir}/Remarkable-${pkgver}"
+}
package() {
_python_site=$(python -c 'import site; print(site.getsitepackages()[0]);')
[ -z ${_python_site} ] && echo "error: could not identify python site_packages directory" && return 1
- msg2 "Extracting data.tar.gz..."
- tar -Jxf data.tar.xz -C "${pkgdir}/"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ cd "Remarkable-${pkgver}"
- msg2 "Moving parts in place..."
+ install -Dm 755 "bin/remarkable" "${pkgdir}/usr/bin/remarkable"
+ install -D "debian/remarkable.mime" "${pkgdir}/usr/lib/mime/packages/remarkable"
+ install -D "data/media/remarkable.svg" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/remarkable.svg"
+ install -D remarkable.desktop "${pkgdir}/usr/share/applications/remarkable.desktop"
+
+ mv data/glib-2.0 "${pkgdir}/usr/share/"
- # python
install -d "${pkgdir}/${_python_site}"
- mv "${pkgdir}/usr/lib/python3/dist-packages/"* "${pkgdir}/${_python_site}/"
+ mv markdown pdfkit remarkable remarkable_lib "${pkgdir}/${_python_site}/"
- # license
- install -d "${pkgdir}/usr/share/licenses/${pkgname}/"
- curl -Ls "${url}/license.txt" \
- -o "${pkgdir}/usr/share/licenses/${pkgname}/license.txt"
-
- msg2 "Fixing module include path..."
- sed -i "s/import styles/from remarkable import styles/" \
- "${pkgdir}/${_python_site}/remarkable/RemarkableWindow.py"
-
- msg2 "Removing unnecessities..."
- rm -r "${pkgdir}/usr/lib/mime"
+ mv data "${pkgdir}/usr/share/remarkable/"
}
-
-# vim:set ts=4 sw=4 et: