summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Göhler2015-06-08 12:06:42 +0200
committerMichael Göhler2015-06-08 12:06:42 +0200
commitdff7f525b7907c45217b4c7455ca82aeefa69d6e (patch)
treecfc1c39705e7671e9ed6661e8ee0180f06ef6fbd /PKGBUILD
downloadaur-dff7f525b7907c45217b4c7455ca82aeefa69d6e.tar.gz
initial submission to aur4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..351541ff2b1b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Michael Goehler <somebody dot here at gmx dot de>
+
+pkgname=remarkable
+pkgver=1.41
+pkgrel=1
+pkgdesc="A free fully featured markdown editor for Linux."
+arch=('i686' 'x86_64')
+url="http://remarkableapp.net"
+license=('MIT')
+depends=('python'
+ 'python-cairo'
+ 'python-gobject'
+ 'python-markdown'
+ 'python-beautifulsoup4'
+ 'python-gtkspellcheck'
+ 'webkitgtk'
+ 'wkhtmltopdf')
+makedepends=('python')
+options=('!emptydirs' '!strip')
+install="${pkgname}.install"
+source=("${pkgname}_${pkgver}_all.deb::http://remarkableapp.net/files/${pkgname}_${pkgver}_all.deb"
+ "${pkgname}.install")
+md5sums=('f4f0a2f3a9746b5c195a9c903e362e0e'
+ '4230de2876e8789bcd5a7cdc84b2a30b')
+
+package() {
+ _python_site=$(python -c 'import site; print(site.getsitepackages()[0]);')
+ [ -z ${_python_site} ] && echo "error: could not identify python site_packages directory" && return 1
+
+ msg2 "Extracting data.tar.gz..."
+ tar -Jxf data.tar.xz -C "${pkgdir}/"
+
+ msg2 "Moving parts in place..."
+
+ # python
+ install -d "${pkgdir}/${_python_site}"
+ mv "${pkgdir}/usr/lib/python3/dist-packages/"* "${pkgdir}/${_python_site}/"
+
+ # license
+ install -d "${pkgdir}/usr/share/licenses/${pkgname}/"
+ curl -Ls "${url}/license.txt" \
+ -o "${pkgdir}/usr/share/licenses/${pkgname}/license.txt"
+
+ msg2 "Fixing module include path..."
+ sed -i "s/import undobuffer/from remarkable import undobuffer/" \
+ "${pkgdir}/${_python_site}/remarkable/RemarkableWindow.py"
+
+ msg2 "Removing unnecessities..."
+ rm -r "${pkgdir}/usr/lib/mime"
+}
+
+# vim:set ts=4 sw=4 et: