diff options
author | kyechou | 2020-11-14 16:00:11 -0600 |
---|---|---|
committer | kyechou | 2020-11-14 16:00:11 -0600 |
commit | c668209a69d2e67bc35a3adf851a369c5d2e4181 (patch) | |
tree | dceca54388d0346054389bfc6ff4458b9deddcfb /PKGBUILD | |
parent | 7ddcc778c43a80634b531869fd2715a8319e49e1 (diff) | |
download | aur-c668209a69d2e67bc35a3adf851a369c5d2e4181.tar.gz |
Use cxx-common
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 17 |
1 files changed, 8 insertions, 9 deletions
@@ -3,21 +3,18 @@ pkgname=remill-git pkgver=v4.0.8.r0.g71c4d067 -pkgrel=1 -_cxxcommonver=0.0.14 +pkgrel=2 pkgdesc="Library for lifting of x86, amd64, and aarch64 machine code to LLVM bitcode" arch=('x86_64') url="https://github.com/lifting-bits/remill" license=('Apache') -depends=('ncurses' 'zlib' 'lib32-glibc') +depends=('cxx-common=0.0.14' 'ncurses' 'zlib' 'lib32-glibc' 'lib32-gcc-libs') makedepends=('git') checkdepends=() provides=('remill') conflicts=('remill') -source=("$pkgname::git+https://github.com/lifting-bits/remill.git" - "https://github.com/trailofbits/cxx-common/releases/download/v${_cxxcommonver}/libraries-llvm1100-ubuntu20.04-amd64.tar.xz") -sha256sums=('SKIP' - '7a680ea1185dfb83bc8a2c3bdb7930e5c1dfc7d78e3af16da65ca525e82ade39') +source=("$pkgname::git+https://github.com/lifting-bits/remill.git") +sha256sums=('SKIP') pkgver() { cd "$srcdir/$pkgname" @@ -25,7 +22,7 @@ pkgver() { } build() { - export TRAILOFBITS_LIBRARIES="$srcdir/libraries" + export TRAILOFBITS_LIBRARIES="/opt/cxx-common/libraries" export PATH="${TRAILOFBITS_LIBRARIES}/cmake/bin:${TRAILOFBITS_LIBRARIES}/llvm/bin:${PATH}" cd "$srcdir/$pkgname" @@ -42,7 +39,7 @@ build() { } check() { - export TRAILOFBITS_LIBRARIES="$srcdir/libraries" + export TRAILOFBITS_LIBRARIES="/opt/cxx-common/libraries" export PATH="${TRAILOFBITS_LIBRARIES}/cmake/bin:${TRAILOFBITS_LIBRARIES}/llvm/bin:${PATH}" cd "$srcdir/$pkgname/build" @@ -53,6 +50,8 @@ check() { package() { cd "$srcdir/$pkgname/build" make DESTDIR="${pkgdir}" install + sed -i "$pkgdir/usr/lib/cmake/remill/remillConfig.cmake" \ + -e "s|$srcdir/$pkgname-$pkgver/build/lib|/usr/include/remill|g" } # vim: set sw=4 ts=4 et: |