summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSkycoder422018-03-22 20:51:39 +0100
committerSkycoder422018-03-22 20:51:39 +0100
commitfaffc5172f703398272402109407d08079f007e9 (patch)
tree016ea86714490a6f0d560170f7f4c07b0fd691da /PKGBUILD
downloadaur-faffc5172f703398272402109407d08079f007e9.tar.gz
initial release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f86c6e89a96c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Felix Barz <skycoder42.de@gmx.de>
+pkgname=remind-me
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="A simple reminder application for desktop and mobile, with synchronized reminders"
+arch=('i686' 'x86_64')
+url="https://github.com/Skycoder42/RemindMe"
+license=('BSD')
+depends=('qt5-base' 'qt5-svg' 'qt5-datasync' 'qt5-mvvmwidgets'' qt5-mvvmdatasyncwidgets')
+makedepends=('qt5-tools' 'git' 'qpmx-qpmsource' 'qt5-mvvmdatasyncquick')
+optdepends=("knotifications: Adds support for KDE notifications, which are more advanced (recompile required)"
+ "repkg: Automatically rebuild the package on dependency updates")
+_pkgfqn=$pkgname-$pkgver
+source=("$_pkgfqn::git+https://github.com/Skycoder42/RemindMe.git#tag=$pkgver"
+ "$pkgname.rule")
+sha256sums=('SKIP'
+ 'c75adc9b16dae39669540352813516e698673a5f2f53034ad3b133c5cab701f3')
+
+prepare() {
+ mkdir -p build
+
+ cd "$_pkgfqn"
+ echo "INSTALL_HEADERS = /usr/include" >> .qmake.conf
+}
+
+build() {
+ cd build
+
+ qmake "../$_pkgfqn/"
+ make qmake_all
+ make
+ make lrelease
+}
+
+package() {
+ cd build
+ cd RemindMeLib
+ make INSTALL_ROOT="$pkgdir" install
+ cd ../daemons/RemindMeDesktopDaemon
+ make INSTALL_ROOT="$pkgdir" install
+ cd ../../gui/RemindMeCore
+ make INSTALL_ROOT="$pkgdir" install
+ cd ../RemindMeWidgets
+ make INSTALL_ROOT="$pkgdir" install
+ cd ../..
+
+ cd "../$_pkgfqn"
+ # gui
+ install -D -m644 icon/remindme.svg "$pkgdir/usr/share/icons/hicolor/scalable/apps/$pkgname.svg"
+ install -D -m644 icon/remindme_error.svg "$pkgdir/usr/share/icons/hicolor/scalable/apps/$pkgname-error.svg"
+
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+